Hola,

Al intentar instalar Business Portal 5.1 sobre SharePoint 2010 edición Standard aparece el siguiente error:

Location:  C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\TEMPLATE\FEATURES\BPReportsCenter

Action:  Install

  Exception:  Value does not fall within the expected range.

   Stack Trace:     at Microsoft.SharePoint.SPListTemplateCollection.get_Item(String strName)

   at Microsoft.Dynamics.SharePoint.Helper.CreateListFromListTemplate(String siteRelativePath, String listName, String listDescription, String listTemplateName)

   at Microsoft.Dynamics.GP.BusinessPortal.ReportsCenter.FeatureInstalled(SPFeatureReceiverProperties properties)

   at Microsoft.SharePoint.Administration.SPFeatureDefinition.DoInstallationCallout(SPSite site, String solutionHash, Boolean fInstall)

   at Microsoft.SharePoint.Administration.SPFeatureDefinition.Install(SPSite site, String solutionHash)

   at Microsoft.SharePoint.Administration.SPFeatureDefinitionCollection.AddCore(SPFeatureDefinition featdef, SPSite site, String solutionHash, Boolean fForce, Boolean fDoValidation)

   at Microsoft.SharePoint.Administration.SPFeatureDefinitionCollection.AddInternal(String relativePathToFeatureManifest, Guid solutionId, String solutionHash, SPSite site, Boolean force, Boolean fDoValidation, SPFeatureDefinitionContext featureDefinitionContext)

   at Microsoft.SharePoint.Administration.SPFeatureDefinitionCollection.Add(String relativePathToFeatureManifest, Guid solutionId, Boolean force)

   at Microsoft.Dynamics.GP.Deployment.SharePoint.Office14.FeatureAdapter.Install(String manifest, Boolean force)

   at Microsoft.Dynamics.GP.Deployment.WindowsInstaller.SharePoint.SharePointInstallFeature.OnPerform(IFeature spFeature, SharePointFeatureInformation spFeatureInfo)

   at Microsoft.Dynamics.GP.Deployment.WindowsInstaller.SharePoint.SharePointFeatureDeploymentProcessor.Process(IFeature featureInterface, SharePointFeatureCustomActionData data)

Este error ocurre cuando se intenta instalar Business Portal 5.1 con SharePoint edición Standard versus Foundation o Enterprise.

Para poder instalar BP 5.1 es necesario tener SharePoint 2010 Foundation o Enterprise edition. 

Estamos en proceso de actualizar la documentación para aclarar este requisito.

Saludos,

Bertrand