My faithful old IBM T60p laptop has been with me for years.  Over time, and every so slowly, it has been running hotter and hotter (especially when running complex spatial queries on SQL Server 2008 or generating map-based reports using the new SQL Server 2008 R2 Report Builder… ;-).  A few weeks ago it got so hot that I had to take it off my lap … and then things went from bad to worse. Here’s the tale…

I decided that it was time to upgrade to Windows 7.  I ordered a new Seagate 7200rpm 320GB hard drive for the laptop.  I took the old internal hard drive out and put it into a NexStar3 USB2.0/eSATA 2.5-inch enclosure …

clip_image001

… and proceeded to do a fresh install of Windows 7. 

The Windows 7 install went flawlessly.  Even the most difficult (anticipated) parts of the install – new drivers for printers and other devices - went very smoothly.  In my case, Windows 7 found all of the drivers automatically over the Net including the driver for the eSATA Express Port card necessary to connect to my NexStar3-enclosed hard drive with all my data on it.  So far so good.

Then bad things begin to happen – for no apparent reason, the laptop started to shut down all by itself.  After having this happen a few times (Windows 7, btw, recovered very nicely each time),  I concluded that the shut downs occurred when the machine got very, very hot – perhaps a heat related shutdown? I did a web search to see if others were having this problem. I appeared to be all alone.  I speculated that it might be one of the following reasons:

1.  My use of an underpowered 65W power supply (its supposed to be a 90W supply but that brick is much larger and I had consequently been using the smaller power supply for the last couple of years).

2. The new operating system, Windows 7.  I imagined that Windows 7 was using the CPU or GPU (or both) just a little bit harder than Vista and this was pushing the laptop “over the edge”.

After swapping out the 65W power brick for the proper 90W unit, it was still overheating and shutting down.  I figured it had to be Windows 7.  Desperate, I sought advice from the hardware technician who supports the SQL Server engineering team.  He had a very simple suggestion:

1. Shut the machine down

2. Use compressed air to blow out accumulated dust from the CPU/GPU ventilation system in the upper left-hand corner of the laptop.

I was skeptical but, having nothing to lose, gave it a try. I liberally blasted both cooling ports on the laptop (see illustration, below) 

image

Several of the air blasts dislodged a noticeable amount of dust.  At the time it didn’t seem like enough to make any significant difference…

I powered up the laptop. Even after several hours of continuous use the machine was running cool and behaving perfectly.  It’s now several days later and the laptop is running like new.  Windows 7 is a delight.  I installed SQL Server 2008 R2 on it easily and moved all of my spatial databases from the external hard drive to the laptop.  I even got up the nerve to try the new Office 2010 beta distribution and again no problems.

The technician did say that it still might warrant a physical inspection of the cooling ports and further dust/cruft removal but this simple trick worked miracles on this particular machine.

Here is a cartoon, which just about sums it up.

Technorati Tags: ,,,