Not sure what to make of this news this morning, and definitely not sure what comment to add on this. So I'll go for the completely factual presentation of something I've just read on the Google Enterprise Blog. I know this is relevant to education customers and partners, because when we talk about our Live@edu email service (which is a Gmail competitor) we are always asked about our browser support, and to confirm that we support the main browsers being used by education establishments today, and students at home. And in many cases, we know that includes older versions of Internet Explorer and other browsers.

Here's the relevant paragraphs from Google's blog:

 

…soon Google Apps will only support modern browsers. Beginning August 1st, we’ll support the current and prior major release of Chrome, Firefox, Internet Explorer and Safari on a rolling basis. Each time a new version is released, we’ll begin supporting the update and stop supporting the third-oldest version.

As of August 1st, we will discontinue support for the following browsers and their predecessors: Firefox 3.5, Internet Explorer 7, and Safari 3. In these older browsers you may have trouble using certain features in Gmail, Google Calendar, Google Talk, Google Docs and Google Sites, and eventually these apps may stop working entirely.

 

(For comparison, here's our list of supported browsers for Live@edu - IE7, Firefox 3.0.1, Chrome 3.0.195.27 and Safari 3.1)