If you are upgrading/migrating a VSS 6.0 source control database to the Visual Studio Team System Version Control System (which is different than VSS 8.0 AKA VSS 2005) you will likely need the VSSConverter tool.  The VSSConverter tool will likely complain that VSS 8.0 is not installed.  I think the error message is insufficient in Beta 2 and I've got an active bug against this.  However here's the background - VSS 2005 has some new components that fix some nasty OLE bugs encountered during upgrade/migration.  The error message is slightly misleading - because it does not mean you have to upgrade your entire source control database to VSS 8.0 prior to migrating it.   It just means you have to have the VSS 2005 (8.0) bits installed on the same machine that is going to be running the converter.  You don't have to use VSS 8.0 for anything else other than that.  When I was doing this I didn't even install it on the VSS 6.0 machine.  In my case VSSConverter and the dependency VSS 8.0 bits were running on a completely separate machine than the one running VSS 6.0.