IE Not Able To Render Some Web Pages?

IE Not Able To Render Some Web Pages?

  • Comments 1

If you are using XPe Feature Pack 2007 (FP2007) you will know that we did a lot of re-factoring work in that release in order to optimize runtime footprint. Specifically we targeted the worst offenders- those components that were most commonly brought into a runtime by a dependency check, and were adding a lot of bloat to the image, when perhaps only one or two files from that component were required. Of course, when these large components were added during the dependency check all their dependencies were subsequently brought in as well. IE was one of the largest components that was re-factored.

One of the drawbacks to this re-factoring effort is that some components that were brought in by dependency check may now not be automatically added to an image. Some examples of these are detailed in this blog article, as well as this one.

This blog covers a customer question about why some web pages (such as http://www.nbc.com/Saturday_Night_Live/video/index.shtml) display correctly on images built with IE in XPe SP2 but not in FP2007. Also errors may occur opening XML files via IE if an XML file uses ISO-8859-1 instead of UTF-8 for example, because of missing CodePage: 28591 (ISO 8859-1 Latin I).

The reason is that the Codepage Application Compatibility component needs to be added to the FP2007 image as it will not be brought in automatically in a dependency check.

- Lynda

Technorati Tags: ,,
Leave a Comment
  • Please add 5 and 3 and type the answer here:
  • Post