The language packs that shipped after Windows Embedded Standard 7 SP1 ("Multilingual User Interface (MUI) Pack 1 for Windows Embedded Standard 7 Service Pack 1”  available in 64-bit and 32-bit versions on Download Center or on ECE) do not automatically bring in the required and optional font dependencies when validating an answer file in Image Configuration Editor (ICE). This is because the version number of the font dependency expressed in the update.mum of the language pack package is inconsistent with the version number of the actual font package in the Distribution Share. Note that the language packs that shipped with SP1 (English, French, German, Italian, Japanese and Spanish) do not have this issue.

To solve this issue manually add the required font pack to the answer file in ICE (and add optional fonts as well, if desired).  For more details on how to apply language packs to an answer file see this article. Here is the list of required and optional fonts for these languages.

 

image

 

Also remember, if you are deploying or redeploying feature sets, you must redeploy the appropriate languages for your image to satisfy dependencies. This is true even if you are not adding new languages to your image, as noted in this article.

 

- Lynda

Technorati Tags: ,