One of the nice features added with Dynamics AX 2009 is the support for 64bit (x64) for the Dynamics AX 2009 Application Object Server and the Dynamics AX 2009 .NET Business Connector.

The fact that the Dynamics AX 2009 Client is however still only available as 32bit (x86) application introduces an issue when Enterprise Portal needs to be updated. The existing post Updating Enterprise Portal from Dynamics AX 2009 Client fails on a 64bit Microsoft Windows Server talks about this in greater detail.

Therefore the command line utility AxUpdatePortal.exe was created. As the post also outlines it is very important to run AxUpdatePortal.exe from an elevated command prompt, and unfortunately the tool does not check if it is running in such.

When you forget to execute AxUpdatePortal.exe from an elevated command prompt, you will notice nothing unusual, a short log file is generated and lists success. However the Enterprise Portal Web Site was actually not updated!


When AxUpdatePortal.exe is not running in an elevated context (with User Account Control being enabled), the utility does not have the needed rights to update all parts of the Enterprise Portal SharePoint web application. So the axwebparts.cab SharePoint Solution will be retracted (as the rights for this operation are given) but not redeployed.  Without this SharePoint Solution important Enterprise Portal web parts are missing and the Enterprise Portal site is generating error messages when browsing to it.

Side note:
Dynamics AX uses the deployment state of the axwebparts.cab SharePoint solution to a SharePoint web application as indicator for a valid Enterprise Portal site. If axwebparts.cab was not deployed AxUpdatePortal.exe does not recognize any valid Enterprise Portal sites in which to deploy to and so the log file is very short. Also subsequent tries running AxUpdatePortal.exe in an elevated context will fail now as long as the SharePoint Solution is not redeployed.


Once the SharePoint Solution is retracted it can only be manually redeployed e. g. from the SharePoint Central Administration site:

  1. Log on at the Enterprise Portal Server
  2. Select Start - Administrative Tools - SharePoint 3.0 Central Administration
  3. Click on the Operations tab
  4. Click at the Solution Management link of the Global Configuration group
  5. Click at the axwebparts.cab solution (this SharePoint solution is only showing up if Enterprise Portal was at least once successfully deployed)
  6. Click at the Deploy Solution button
  7. In the group Deploy When select Now
  8. In the group Deploy To make sure you have chosen your Enterprise Portal site
  9. Make also sure you have selected Install assemblies to: Global assembly cache to deploy the solution correctly
  10. Click at the OK button
  11. Wait until the deployment finished (if you have more than one Enterpriese Portal site, repeat the steps 5 to 11 for each site)