During deployment of Microsoft Dynamics AX 2009 Workflow on one of environments running on Windows Server 2008 R2 I was able to validate Workflow URL in Basic > Setup > Settings for workflow. I was also able to access Workflow page from AOS server, but when running the workflow processing batch job I got an error in the Windows Event viewer for Microsoft Dynamics Ax Workflow:

Exception thrown in SysWorkflowEventDispatcher-onAcknowledgeWorkflowActivation SysWorkflowEventDispatcher-raiseWorkflowActivationEvent : Web service failed: workflow id 000048_201 System.Web.Services.Protocols.SoapException: Server was unable to process request. ---> System.ComponentModel.Win32Exception: Access is denied
at System.Diagnostics.ProcessManager.OpenProcess(Int32 processId, Int32 access, Boolean throwIfExited)
at System.Diagnostics.NtProcessManager.GetModuleInfos(Int32 processId, Boolean firstModuleOnly)
at System.Diagnostics.Process.get_MainModule()
at System.Workflow.Runtime.PerformanceCounterManager.SetInstanceName(String instanceName)
at System.Workflow.Runtime.WorkflowRuntime.StartRuntime()
at Microsoft.Dynamics.Framework.Workflow.AxWorkflowRuntime.get_WindowsWorkflowRuntime()
at Microsoft.Dynamics.Framework.Workflow.AxWorkflowRuntime.CreateWorkflowInstance(XmlReader workflowDefinitionReader, Guid workflowInstanceId)
at Microsoft.Dynamics.Framework.Workflow.WorkflowInstanceManager.Activate(Activity workflowRoot, Guid workflowInstanceId)
at Microsoft.Dynamics.Framework.Workflow.WorkflowInstanceManager.Activate(WorkflowActivationRequest activationInfo)
at Microsoft.Dynamics.Framework.Workflow.WebServices.AxaptaWorkflowInstance.Activate(WorkflowActivationRequest activationRequest)

The error was caused by IIS Authentication settings where not only Windows authentication was Enabled but also Basic. To resolve this issue we followed the following steps:

- Log in as a local administrator on the Windows Server 2008 R2, and run Start -> All Programs -> Administrative Tools -> Internet Information Services (IIS) Manager

- In the left-hand pane, click on Sites, and then click on MicrosoftDynamicsAXWorkflow50 web application

- From the right-pane in IIS section double click Authentication

- Make sure that Basic Authentication is disabled