The July CTP release of Visual Studio Team System is really a step foward from the Beta 2.  Performance, polish and reporting are some really big improvements. 

That said, it has a few blemishes.  I'm trying to put together a VPC image of our July CTP, so I've had to work through a few of these issues.  As I do so, I thought I would aggregate the workarounds - provided courtesy of others - that I've found.

Here is my list so far:

Creating a new Test Project results in a null reference exception

The quality tools product team posted a quick fix for this problem at: https://blogs.msdn.com/vstsqualitytools/archive/2005/08/09/449268.aspx.  I chose the 'fix' option and it worked well for me.

Team Foundation Alerts do not work for check-in notifications

This issue was noted in our forums: http://forums.microsoft.com/msdn/ShowPost.aspx?PostID=74842.  See Bhavik's solution at the end of that thread.

Null reference exception when viewing the History of a node in Version Control

For some odd reason, only one of my projects in Version Control was affected by this.  Whenever I try to view a history from the root of this folder, I get a null reference exception.  The fix is described below:

  1. Use the SQL Server tools to connect to the VSTEAMSCC database
  2. In a query window, run the following query SELECT * FROM tbl_changeset
  3. In the results, the ownerid and committerid column should not contain 0
  4. For the ones that do contain a 0, update those rows with a query like:

            UPDATE tbl_changeset

            SET ownerid=<use the appropriate owner id>

            WHERE changesetid=<use the appropriate change set id from the query above)

            UPDATE tbl_changeset

            SET commiterid=<use the appropriate owner id>

            WHERE changesetid=<use the appropriate change set id from the query above)

Team Foundation Build is not working

Ah, this was pilot error :)  I thought I had set permissions correctly the first time, but I tried again and Team Build is now working for me.