Back in Feb 2006 I was asked by a number of ISV about what are the "gotyas" for applications built for Framework 1.1 running on a machine with 2.0 installed. I had a trawl and found we were weak on information in this area. Whilst for many apps there will be "no issue", there were plenty of edge cases which potentially would lead to problems.

I am pleased to say we now have plenty of information in this space:

I would advise folks with 1.0 and 1.1 applications to spend time looking at the above. But remember in most cases everything will be fine e.g.

Machine with Framework 1.1 installed and 100 stand alone managed code apps using it
Install Framework 2.0
All 100 apps still use 1.1
Build app in VS 2005
Install app on machine and ... it will use 2.0 Framework
All orginal 100 apps still use 1.1