Blog - Title

Access denied by Business Data Connectivity

Access denied by Business Data Connectivity

  • Comments 16

Sometimes when you are creating and modifying External Content Types (ECT), you may see the error Access denied by Business Data Connectivity.

This blog is inactive.
New blog: EricWhite.com/blog

Blog TOC

The normal course of events when setting up an ECT is that after making sure your data source is properly configured, you use SharePoint Designer to set up the ECT.  Then, you need to give permissions to specific users and groups for that ECT.  You use SharePoint 2010 Central Administration to assign those permissions.

One problem that can produce the above error message is that modifying the ECT in SharePoint Designer clears those permissions.  If you modify the ECT in SharePoint designer, you need to go back into Central Administration and set permissions again.

Of course, you could be receiving this error because you’ve never set permissions.

The following procedure shows how to set them.

You open SharePoint 2010 Central Administration on the server that will consume the web service, and click on Manage service applications.

Then you click on Business Data Connectivity Service.

Then you select the ECT and click Set Object Permissions.

Then in the resulting Set Object Permissions dialog box, you add yourself, or someone else, or a group, or All Authenticated Users, and assign them the permissions that you want to give them.

Leave a Comment
  • Please add 1 and 1 and type the answer here:
  • Post
  • Thank you! This fixed my problem! Nice Post!!

  • OK... but :

    1) What does it mean to give "set permissions" permission to all users ; in which context will that use ?

    2) I tried it ; and I get another error (very common to a lot of shp developpers, it seems)

    ---

    Impossible d’afficher ce composant WebPart. Pour résoudre le problème, ouvrez cette page Web dans un éditeur HTML compatible avec Microsoft SharePoint Foundation tel que Microsoft SharePoint Designer. Si le problème persiste, contactez l’administrateur du serveur Web.

    ID de corrélation :b436f9f6-23f1-4146-902f-f1a2f2d783a5

    ---

    That looks like a bug, no ?

  • Thank you for this straightforward post.

    Mine disappeared, but didn't reappear until I added "All Users (windows)"

    in Set Object Permissions.

  • A very good post. Thank you very much.

  • Thank you So Much. It Fixed my Issue.

  • This solution worked for me too as documented in this post.  Thank you.

  • This is what am looking for. Thanks a lot for Sharing.

  • Hi,

    I have the same error message as JF Fustec when I tried this solution :

    Unable to display this Web Part. To troubleshoot the problem, open this Web page in a Microsoft SharePoint Foundation-compatible HTML editor such as Microsoft SharePoint Designer. If the problem persists, contact your Web server administrator.

    Correlation ID:8061351f-1b27-4198-b1b8-4603893011ab

  • Thank you so much! You've saved me a lot of time.

  • Thank you! This fixed my problem! Nice Post!!

  • Thanks for posting this information. You don't need to give all the users full access to the connection. read access is enough.

  • Rafael there is no "read access" in the permissions config. What are you talking about?

  • Hi I am getting this error while creating 'External Content Type' with 'WCF Service' as a data source.

    Please help me to solve my problem.

    Thank you.

  • This final step jumps up and bites me every time!  Thanks!  Exactly the solution I needed.  After ALL the other setup (SSS, BDC, SQL Server...) I always forget to go to BDC and grant perms there too!

  • Thank You! fixed my issue.

Page 1 of 2 (16 items) 12