Expression Blend and Design

The team blog of the Expression Blend and Design products.

Minor Update to The Expression Blend 4 Release Candidate

Minor Update to The Expression Blend 4 Release Candidate

  • Comments 7

As most of you know, last week we released the release candidate version of Expression Blend 4. Shortly after many of you had a chance to play with it, some of you reported that Expression Blend crashes during launch.

If you are one of those people whose Expression Blend crashes after launch, please download this minor revision of the release candidate we released last week:


blendicon_3 Expression Blend 4 Release Candidate (Updated)


If you aren’t having any problems launching Blend, you do not have to upgrade. There are no new features or changes besides some changes to make sure Expression Blend runs properly on launch.

Submit Error Reports!
We were able to detect this issue thanks largely through the error reports those of you with this crash submitted. We constantly go through all of the crash reports we receive, and we try to fix as many of them as possible.

While we hope you never have to experience crashes from running Expression Blend, if you do experience a crash, please do submit the error reports!

Thanks,

- The Expression Blend Team

Leave a Comment
  • Please add 8 and 4 and type the answer here:
  • Post
  • I have two comments on the Blend RC4 release:

    1) The connect link provided on the download page doesn't really work: there is no way to specify that reported issues apply to Blend RC 4, only to older versions of blend  (at least that was the case when I tried it last week).

    2) As a substitute I reported an issue I had in an existing thread on the same topic on the forums (under the nickname 'Yoco'): http://social.expression.microsoft.com/Forums/en-US/blend/thread/5c158f46-abca-44c7-ba2e-6a85fed5bc64 . I haven't seen any confirmation that this information was picked up though. Long story short: the UI is almost unreadable on systems that don't have the Segoe UI font installed (for instance windows XP systems without Office 2007 or newer), and the installer doesn't attempt to install it. May I suggest you include this font in the installer?

  • The link you give has the old version number displayed on the page, 4.0.20408.0 - not the new number, 4.0.20421.0. Somewhat confusing.

  • Greg - thanks for pointing that out. That is something I've let a few of our colleagues know, and they will be addressing that version discrepancy shortly.

    Cheers,

    Kirupa

  • I have had trouble installing blend 4...

    many product keys (from link in setup)... always result in

    'Key is Not Valid...' Error

    Any Suggestions?

    j.hasslocher@gmail.com

  • No way to register the Blend 4 RC build.

    This page is broken: http://www.microsoft.com/expression/productkey.aspx   :(

    Please advise.

  • Bo - I was able to access that page in both IE, Firefox, and Chrome. What specific error are you receiving?

    Thanks,

    Kirupa

  • Bo - sorry, I now see what you mean. After you fill out the form, no key is being displayed. Thanks for pointing this out - we hope to have this issue addressed shortly.

    Thanks,

    Kirupa

Page 1 of 1 (7 items)