Hi all, apologies for the pause in blogging. This is holiday season and I am … having plenty of holiday :-) (Which makes a nice change)

A couple of folks have asked me recently about Visual Basic versions and .NET Framework versions and how they tie up. I thought I would have a stab at a concept map to demonstrate the relationship.

Note that things got very different with the release of VB9. VB9 targets three versions of the framework and really brings to the fore the separation between the language/compiler and the runtime .NET Framework. What that means is new VB9 features (such as extension methods) will work just fine on a machine with only .NET Framework 2.0 (or 3.0) installed. Very clever stuff and one of the reasons VB9 (and VS2008) is the right choice even if your world is about .NET Framework 2.0.

NB: VB9 = Visual Basic 2008, VB8 = Visual Basic 2005, VB7 = Visual Basic.NET, VB6 = “the good old days” :-)

image