Having trouble with PoserFusion Shelf in Maya?

Having trouble with PoserFusion Shelf in Maya?

  • Comments 15

If you are encountering errors with Poser Fusion shelf buttons in Maya such as "Error: No Selection, or the Currently Selected object is not linked to a Poser file", then try the below steps and see if its helps.

First of all ensure that your POSER_LOCATION environment variable is set correctly. It should read something like "C:\Program Files\Smith Micro\Poser Pro".

Next, ensure that the PoserFusion plug-in is loaded in Maya. You can do this by going to Window > Settings|Preferences > Plugin Manager and then checking the "MpzFile.mll" to be loaded state.

Once these two steps are done, you should be able import any Poser file into Maya. You should select the "Poser(*.*)" option in the file dialog while importing the Poser file.

Once the file import succeeds, now all your PoserFusion shelf buttons start working correctly. Details on how to use these shelf buttons can be found in the PoserFusion for Maya section starting on page 38 of the Poser Pro Reference Manual.pdf available in the Poser Pro application folder.

  • PingBack from http://www.basketballs-sports.info/better-basketball/?p=1148

  • I have been working with Poserfusion for Maya for over a month and it still wont work.  When I try to import I get an error reading file.  The shelf shows up but nothing happens.  I have tried poser files from complex to simple and everybody who has this plugin that I have spoken with has this problem.

    Also above you mention the poser location environment where would that be found is it where poser is installed or is there a tab in Maya.

    Thank you.

  • Hello Jack Halsey,

    The POSER_LOCATION is a system environment var - we need to set it in the system settings. Go the MyComputer | Properties and then Advanced Settings and then "Environment Variables" button.

    Under the System Variables check for the entry named "POSER_LOCATION" and ensure that it points to the Poser installation directory. If the variable doesn't exist create one with the variable name "POSER_LOCATION" (without quotes) and variable value <your poser installation directory path>.

    Is the "MpzFile.mll" plug-in loaded in Maya? Do you see the "Poser(*.*)" in the file dialog of Maya Import?

    Thx.

  • Wow that was fast thank you.  Yes I have the mpzfile.mil loaded and the Poser** choice in the Maya import.

    Here is what I did find.  Under poser location it  points to poser 7 instead of poser pro as I have both installed.  So should I just delete the poser 7 reference and put in the poser pro location or add another poser reference and if so how does one accomplish this.

    Again thank you.

  • Hello Jack Halsey,

    Yes, Modify the currently POSER_LOCATION variable value so that it points to the PoserPro installation directory instead of the Poser 7.

    (Either you can delete the existing one and add a new one with correct value, or just update the existing one with the correct value. I prefer the second approach as its simpler.)

    Once you have updated the value, open a new command prompt and then issue the command:

    C:\> SET

    It should list the current environment variables for your system. There in the list you should see the correct value against the POSER_LOCATION.

    Finally, start Maya afresh and do the import (with the Poser(*.*) option). Go to the Script Editor (Window | General Editors | Script Editor) and check the recent list of commands executed. You should see something like

    getenv POSER_LOCATION;

    Check the immediate value in the next line - it should indicate your PoserPro installation directory.

    At this point things should be working correctly.

    All the best.

    Gopalakrishna Palem

    http://www.geocities.com/krishnapg/

  • Hello

    It appears to work thank you.  I am running windows vista so after I made the change in the System Variables and closed it.

    My command prompt states C:\Users\Jack and I am not sure how to change it to C:\>Set.  I opened Maya and nothing was under the script editor.

    It appeared to open the file but it said it imported with an error but I seen the scene.  Will explore and advise.

    Please advise if I need to do anything else and THANK YOU!!!!!!  Had been wrestling with this for over a month.

  • Thank you, having the same problem with C:\SET

    Is this a Vista fix or does it also work with XP pro?

  • Hello,

    We can ignore the current directory for our purpose. The command "SET" only lists the environment variables - we do this just to ensure that our change to our POSER_LOCATION is correct.

    We can give the command from any location - for example, the following should also do fine.

    C:\Users\Jack> SET

    And we need to open the Script Editor "after" importing the Poser Scene. Then we should be able to see the "getenv POSER_LOCATION;" command in the upper window somewhere. This is once again, just a test to ensure that our POSER_LOCATION variable was set properly.

    Setting the environment variable POSER_LOCATION to the correct Poser location path (using the MyComputer | Properties and then Advanced Settings and then "Environment Variables" button) should work fine for XP too.

    Thank you.

  • Hello

    You have solved a lot of my problems, thank you.  I am still having the following problems.

    It takes forever to import even a simple poser scene and there is a popup that states it has encountered problems so I should check the script editor.

    I open the script editor and these are some of the problems...)the entire text is very long and some of it doesnt apply so I am giving you a sample.......

    getenv POSER_LOCATION;

    // c:/program files (x86)/Smith Micro/Poser Pro //

    // Creating Poser Universe...

    // Creating Poser Scene...

    // Opening Poser file...

    // Error: line 1: Too many arguments.  Expected 0, found 1. //

    // Error: line 1: The place2dTexture 'poserTX29place2D' has no '.outColor' attribute. //

    // Error: line 1: The place2dTexture 'poserTX29place2D' has no '.outColor' attribute. //

    // Error: line 1: Too many arguments.  Expected 0, found 1. //

    // Error: line 1: The place2dTexture 'poserTX29place2D' has no '.outColor' attribute. //

    // Error: line 1: The place2dTexture 'poserTX29place2D' has no '.outColor' attribute. //

    evalDeferred("mpzAssignShader -f mpzFile1 -s SG \"4sided_stairs_B\" -s SG1 \"4sided_stairs_D\" -s Preview_MTSG \"Preview\" -s Skirt_B_MTSG \"Skirt_B\" -s Skirt_A_MTSG \"Skirt_A\" -s Rope_Hooks_MTSG \"Rope_Hooks\" -s Sleeves_MTSG \"Sleeves\" -s Ropes_D_MTSG \"Ropes_D\" -s Post_Hooks_MTSG \"Post_Hooks\" -s TB_Hooks_MTSG \"TB_Hooks\" -s TBuckles_Bot_Half_MTSG \"TBuckles_Bot_Half\" -s Turnbuckle_Stuffing_MTSG \"Turnbuckle_Stuffing\" -s TBuckles_Top__Half_MTSG \"TBuckles_Top__Half\" -s Skirt_C_MTSG \"Skirt_C\" -s Apron_MTSG \"Apron\" -s Ring_Posts_MTSG \"Ring_Posts\" -s Ropes_A_MTSG \"Ropes_A\" -s Ropes_B_MTSG \"Ropes_B\" -s Ropes_C_MTSG \"Ropes_C\" -s Skirt_D_MTSG \"Skirt_D\" -s SkinTorso_0_MTSG \"SkinTorso:0\" -s Nipples_MTSG \"Nipples\" -s SkinNeck_MTSG \"SkinNeck\" -s SkinHip_MTSG \"SkinHip\" -s SkinFeet_MTSG \"SkinFeet\" -s SkinLeg_MTSG \"SkinLeg\" -s Toenails_MTSG \"Toenails\" -s SkinForearm_MTSG \"SkinForearm\" -s SkinArm_MTSG \"SkinArm\" -s SkinHand_MTSG \"SkinHand\" -s Fingernails_MTSG \"Fingernails\" -s SkinHead_MTSG \"SkinHead\" -s SkinScalp_MTSG \"SkinScalp\" -s Lips_MTSG \"Lips\" -s EyeSocket_MTSG \"EyeSocket\" -s InnerMouth_MTSG \"InnerMouth\" -s Nostrils_MTSG \"Nostrils\" -s Lacrimal_MTSG \"Lacrimal\" -s Eyelashes_MTSG \"Eyelashes\" -s Eyebrows_MTSG \"Eyebrows\" -s Teeth_MTSG \"Teeth\" -s Gums_MTSG \"Gums\" -s LCornea_MTSG \"LCornea\" -s LEyewhite_MTSG \"LEyewhite\" -s LPupil_MTSG \"LPupil\" -s LIris_MTSG \"LIris\" -s RCornea_MTSG \"RCornea\" -s REyewhite_MTSG \"REyewhite\" -s RPupil_MTSG \"RPupil\" -s RIris_MTSG \"RIris\" -s Tongue_MTSG \"Tongue\" -s PubicHair_MTSG \"PubicHair\" -s bow_MTSG \"bow\" -s strap_MTSG \"strap\" -s hat_MTSG \"hat\" -s band_MTSG \"band\" -s ToeNails_0_MTSG \"ToeNails:0\" -s SkinBody_MTSG \"SkinBody\" -s FeetBottom_MTSG \"FeetBottom\" -s Tusks_MTSG \"Tusks\" -s FingerNails_MTSG \"FingerNails\" -s EyeWhite_MTSG \"EyeWhite\" -s Iris_MTSG \"Iris\" -s Pupils_MTSG \"Pupils\" -g polySurfaceShape1 \"4SidedStairsB\" -g polySurfaceShape3 \"4SidedStairsD\" -g polySurfaceShape5 \"Floor_1\" -g polySurfaceShape7 \"BODY:1\" -g polySurfaceShape9 \"BODY:2\" -g polySurfaceShape11 \"BODY:3\"");

    // Warning: Errors have occurred while reading this scene that may result in data loss.

    Please check the Script Editor for details. //

    // G:/RendersP7/brutgetsup.pz3 //

    // 1 //

    sets -e -fe SG polySurfaceShape1.f[0] polySurfaceShape1.f[1] polySurfaceShape1.f[2] polySurfaceShape1.f[3] polySurfaceShape1.f[4] polySurfaceShape1.f[5] polySurfaceShape1.f[6] polySurfaceShape1.f[7] polySurfaceShape1.f[8] polySurfaceShape1.f[9] polySurfaceShape1.f[10] polySurfaceShape1.f[11] polySurfaceShape1.f[12] polySurfaceShape1.f[13] polySurfaceShape1.f[14] polySurfaceShape1.f[15] polySurfaceShape1.f[16] polySurfaceShape1.f[17] polySurfaceShape1.f[18] polySurfaceShape1.f[19] polySurfaceShape1.f[20] polySurfaceShape1.f[21] polySurfaceShape1.f[22] polySurfaceShape1.f[23] polySurfaceShape1.f[24] polySurfaceShape1.f[25] polySurfaceShape1.f[26] polySurfaceShape1.f[27] polySurfaceShape1.f[28] polySurfaceShape1.f[29] polySurfaceShape1.f[30] polySurfaceShape1.f[31] polySurfaceShape1.f[32] polySurfaceShape1.f[33] polySurfaceShape1.f[34] polySurfaceShape1.f[35] polySurfaceShape1.f[36] polySurfaceShape1.f[37] polySurfaceShape1.f[38] polySurfaceShape1.f[39] polySurfaceShape1.f[40] polySurfaceShape1.f[41] polySurfaceShape1.f[42] polySurfaceShape1.f[43] polySurfaceShape1.f[44] polySurfaceShape1.f[45] polySurfaceShape1.f[46] polySurfaceShape1.f[47] polySurfaceShape1.f[48] polySurfaceShape1.f[49] polySurfaceShape1.f[50] polySurfaceShape1.f[51] polySurfaceShape1.f[52] polySurfaceShape1.f[53] polySurfaceShape1.f[54] polySurfaceShape1.f[55] polySurfaceShape1.f[56] polySurfaceShape1.f[57] polySurfaceShape1.f[58] polySurfaceShape1.f[59] polySurfaceShape1.f[60] polySurfaceShape1.f[61] polySurfaceShape1.f[62] polySurfaceShape1.f[63] polySurfaceShape1.f[64] polySurfaceShape1.f[65] polySurfaceShape1.f[66] polySurfaceShape1.f[67] polySurfaceShape1.f[68] polySurfaceShape1.f[69] polySurfaceShape1.f[70] polySurfaceShape1.f[71] polySurfaceShape1.f[72] polySurfaceShape1.f[73] polySurfaceShape1.f[74] polySurfaceShape1.f[75] polySurfaceShape1.f[76] polySurfaceShape1.f[77] polySurfaceShape1.f[78] polySurfaceShape1.f[79] polySurfaceShape1.f[80] polySurfaceShape1.f[81] polySurfaceShape1.f[82] polySurfaceShape1.f[83] polySurfaceShape1.f[84] polySurfaceShape1.f[85] polySurfaceShape1.f[86] polySurfaceShape1.f[87] polySurfaceShape1.f[88] polySurfaceShape1.f[89] polySurfaceShape1.f[90] polySurfaceShape1.f[91] polySurfaceShape1.f[92] polySurfaceShape1.f[93] polySurfaceShape1.f[94] polySurfaceShape1.f[95] polySurfaceShape1.f[96] polySurfaceShape1.f[97] polySurfaceShape1.f[98] polySurfaceShape1.f[99] polySurfaceShape1.f[100] polySurfaceShape1.f[101] polySurfaceShape1.f[102] polySurfaceShape1.f[103] polySurfaceShape1.f[104] ;

    // SG //

    Please advise and thank you.

  • One more thing.  The scene was originally created in Poser 7..so to be sure I loaded it into Poser Pro and it loaded perfectly with no problems.  I saved it under a different name in poser pro.

    When I opened it in Maya I got the same problems.

  • The error seems to be related to a texture object

    // Error: line 1: The place2dTexture 'poserTX29place2D' has no '.outColor' attribute.

    Not sure about the exact reason though. Perhaps the Maya experts at http://www.highend3d.com/ forums might be able to give some more details about these errors.

    Thank you.

  • Thank you.

    Will ask on those forums and post back.  Thank you.

  • I have a wierd problem. All is set properly and when I try to load the plug-in (mpzFile.mll) in Maya it gives me error saying

    // Error: line 1: The specified procedure could not be found.

    (mpzFile) //

    and it doesn't load the plug-in.

    Any idea why its happening?

    I am using Maya 8.5.

    Thank you.

  • Hello kart,

    Please check if the scripts directory is valid and that it has all the required scipt files there.

    Usually it should be something like c:\program files\Smith Micro\PoserFusion\Maya\<version>\scripts\

    P.Gopalakrishna

    http://www.geocities.com/krishnapg/

  • My environmental variables reads the correct directory for Poser Pro. However, when I check it with the command prompt, it reads the wrong directory still. How can this be corrected?

Page 1 of 1 (15 items)
Leave a Comment
  • Please add 3 and 7 and type the answer here:
  • Post