The Windows Azure Tools for Microsoft Visual Studio runs on top of either Visual Studio 2008 Standard (or above) or Visual Web Developer 2008 Express Edition. However, it requires the SP1 version of these and the installer will block if either of these are not at SP1 level with the following message: 

Windows Azure Tools for Microsoft Visual Studio requires Visual Studio 2008 SP1 or Visual Web Developer 2008 Express Edition SP1. If you installed pre-SP1 components after upgrading to SP1, please reinstall SP1 and try again.

We're finding that some users that have both of these installed on their machines are left wondering what's wrong when they see this error message for a variety of reasons: some installed the Express version a long time ago and didn't remember they still had it, some weren't aware that installing the SP1 update for Visual Studio doesn't actually update the Express versions on the machine (a separate SP1 update exists for each of those), and some are expecting that it would work if only one of them was updated.

In the end, we require any versions you have be at SP1 level to reduce confusion and problems in the future. That said, we'll work on improving the error message (more specific and more actionable) in our next release.

In the meantime, if you're seeing this error with our October CTP, make sure you've applied the SP1 update for whatever versions of Visual Studio 2008 you have on your machine. You can find the updates here:

Also, if you're one of those folks that are using a non-Express version of Visual Studio full time now and no longer plan on using the Express Edition, uninstalling the Express Edition should also get you past the installer error.