I've been playing with Vista on my IBM/Lenovo X41 Tablet and it's been a lot easier to setup than setting up Tablet hardware was on Vista Beta1, but still it's a hassle.

There are no less than 10 "Unknown Device" entries in my Device Manager following a clean install.  Yeah, I do upgrade installs, but rarely, since I install new bits so often. Besides, as mentioned earlier, the vast majority of end users will receive Vista preinstalled on new hardware.  Almost all of these "Unknown Device" entries go away when you install XP-era drivers*.

The one IBM/Lenovo preload feature that I've kind of fallen in love with is the Biometric logon (ThinkVantage Fingerprint). It wraps the XP logon process and no longer works on Vista.  I guess this proves that you never know you need/love something til you use it.

Vista Beta2 is chugging along on schedule (from my perspective) barring any more major bugs like the one I found where if you uninstall your digitizer, you can't reinstall it except by reinstalling Vista. Haha! This turned out to be a core Vista driver install mechanism bug. If I were Mini-Microsoft, I'd be calling for some engineers to be fired about now. (and I'd be ordering some test monkeys to do the work that I'm doing, but that's another, future blog posting...)

See you in Vegas for DevConnections!!

*Caveat: internally, I have access to something called the Supplemental Driver Pack, essentially a CD's worth of XP-era drivers for legacy devices that are not yet fully supported by Vista, conveniently rolled up for internal/dogfooding use.