Brian Rogers: Removing complexity slowly.

Windows Installer XML (WiX), Heat.exe, Windows CE Release and many other work related items...

Troubleshooting Red ‘X’s in the Compact 7 Installation

Troubleshooting Red ‘X’s in the Compact 7 Installation

  • Comments 12

Hey everyone, we have been fielding some questions about installation requirements for Compact 7. I had Kyle Roe write up some general troubleshooting instructions for you.


As with all software installations, there are times when WindowsEmbeddedCompact7.exe cannot complete the install successfully. Great effort has been made prevent the installation from failing. Sometimes the installation requires other software to be installed first. In the case of Platform Builder, Visual Studio 2008 and Visual Studio 2008 SP1 are the prerequisites. Windows Embedded Compact 7 will search for the prerequisites when it starts. This is part of the action taken while the Splash screen is displayed. ( as a side note, the Splash screen can be moved to show the program has not locked up.)

So what happens if the prerequisites are not found?

You, the user, will see Red X’s next to options that require prerequisites to be meet.

RTM display.

clip_image001

With the updated software, a message is displayed explaining what prerequisites are required.

clip_image002

So why is Shared Source greyed out with a red X next to it when all the prerequisites are installed?

Evaluation copies of the software do not come with Shared Source. But you can access more information about Shared Source right from the link the description field.

clip_image003

If you are still having trouble with WindowsEmbeddedCompact7.exe, you can either reach out help, or investigate the issue yourself. For both options you will need to access the log files that the software creates. These log files are in the user profile temp folder, of the user who ran the software. The easiest way to get to that folder is to click on Start and Select Run.

clip_image004

In the text window type %temp%, click Ok.

clip_image005

That will open your temp folder and you should see the log files listed.

clip_image006

All four of log files shown were created by the software. When some prerequisites are not found, an entry like the highlighted one here will explain why you are having a problem.

clip_image007

The snippet above is an entry showing that Visual Studios 2008 could not be found on the computer.

When Visual Studios 2008 is found at the proper version, an entry like this can be found in the log. clip_image008

If you are having issues, I hope this helps explain how to trouble shoot it. In our efforts, we have attempted to prevent as many issues as we can, and present as much information as possible when the issue can not be prevented. Let me know how we are doing.

Leave a Comment
  • Please add 6 and 1 and type the answer here:
  • Post
  • Despite my best efforts to remove the Compact 7 CTP, I'm still having trouble installing the Compact 7 release (from DVD or the eval download).  Thanks for pointing out these log files.  I can see that WindowsEmbeddedCompact7.004c.log points to faliure in MS_OSCommon_001d.log, which states "Another version of this product is already installed.  Installation of this version cannot continue."  Is there any known solution to uninstalling CTP without completely reinstalling Windows?

  • @Gary I will do my best to resolve this issue with you. The machine sounds to be in a bad state. Unfortunately we did not support direct upgrading from the CTP release to our RTM. It sounds like you are actually trying to uninstall using the RTM installer (from disk) rather than the CTP installer.

    First, please go to 'Add/Remove Programs' (or 'Programs and Features' on Vista or higher) and attempt an uninstall of Windows Embedded Compact 7 (which ever one is there) and make sure that Windows Embedded Silverlight Tools (WEST) is uninstalled as well  (if you had installed it). WEST does not uninstall with Compact 7.

    Please let me know what happens in the log files when you run the installation from Add/Remove Programs and I will work with you on this from there.

  • The CTP installer never uninstalled for me.  I never saw the item in Add/Remove Programs.  The distributor who sold me C7 RTM DVDs tried to help, and explained that the CTP didn't uninstall correctly and I had to remove some items manually, but I never got RTM to install (DVD or eval download).

  • In Add/Remove programs, I don't see Compact 7, nor "Windows Embedded Silverlight", but I do see "Microsoft Silverlight".  Should I uninstall that?

    Also, in C:\Program Files I see "Microsoft Platform Builder", "Microsoft Remote Framework Tools", "Remote Tools Framework", "Windows Embedded Compact 7", and "WindowsEmbeddedCompact7TestKit".  Should I delete all these?

  • There are additional details in my posting on the Windows Embedded Compact Platform Development forum, subject "Error installing Compact 7 release after CTP".  I tried to post a link here, but it didn't appear...

  • @Gary I wouldn't manually delete anything. That actually wouldn't help you much. Oddly enough, I would try to reinstall the CTP release. If you can get it to run through a basic install it will be able to uninstall. Otherwise we will have to work through a very intensive manual removal.

  • Since reinstalling VS 2008, the CTP install has failed.  The error message I'm getting is:

    "A network error occurred while attempting to read from the file: C:\Documents and Settings\All Users\Application Data\PkgCache\{48269A19-7482-4E5D-81DB-48B713476A59}V7.0.6023.0\CTK\WindowsEmbeddedCompact7TestKit.msi"

    I tried deleting all contents of the folder C:\Documents and Settings\All Users\Application Data\PkgCache,

    but I still encounter the same error message.

  • Something very similar appears in %temp%\MSI_CTK_0023.log.  OriginalDatabase is set to

    C:\Documents and Settings\All Users\Application Data\PkgCache\{48269A19-7482-4E5D-81DB-48B713476A59}V7.0.6023.0\CTK\Windows Embedded Compact Test Kit.msi

    After the log entry "Cleaning up uninstalled install packages, if any exist"

    I see, "MainEngineThread is returning 1603"

    And "Destroying RemoveAPI object."

    It seems to quit after this.

    Do you have suggestions for getting around this error?

  • @Gary can you email me through this blog using "Email Blog Author" so we can work through this issue.

  • Thanks for helping me get the CTP uninstalled.  After reinstall of the CTP, it

    uninstalled successfully, and the RTM on DVD seemed to install fine.

    When I initially loaded VS 2008, I got an error message:

    Package ‘VSCoreconPkg Package’ has failed to load properly…

    But after shutdown and reboot of the PC, it seems to load VS OK.

  • I created a CEPC OS design and got the message:

    The Debugger failed to obtain the SID_SPbRemoteServiceMgr service and may be unstable.  The error code is 80004002.  A reinstall of Platform Builder may be required.

    I had to kill PB via task manager.  After reboot, I tried to create the OS design again and got the same error message.

    After another reboot, I selected the new project from the Recent Projects list of the Start Page, and got the same message.

    Any ideas?

  • The VS 2008 output window displayed this line over and over:

    The VSCoreconPkg Package ({CB721776-3D19-4F91-87E3-171DEA2B126E)} did not load because of previous errors.  For assistance, contact the package vendor.  To attempt to load this package again, type 'devenv /resetskippkgs' at the command prompt.

    So I tried:

    "C:\Program Files\Microsoft Visual Studio 9.0\Common7\IDE\devenv.exe" /resetskippkgs

    This loaded VS with a message window:

    Package Load Failure

    Package 'VSCoreconPkg Package' has failed to load properly ( GUID = {CB721776-3D19-4F91-87E3-171DEA2B126E}). Please contact package vendor for assistance.  Application restart is recommended, due to possible environment corruption.  Would you like to disable loading this package in the future?  You may use 'devenv /resetskippkgs' to re-enable package loading.

    Thanks for the tip to use Add/Remove Programs, Change Windows Embedded Compact 7 and run a repair on Platform Builder only.

    Now, I can load, build, and download my OSDesign.

Page 1 of 1 (12 items)