I just discovered that the 2.0 release of the Fabrikam Jets example on code gallery (described in this blog post) contained the original version 1.0 code that worked with OAuth WRAP v0.8, instead of the new version 2.0 code that works with OAuth WRAP v0.9. Apparently, I uploaded the wrong file back in January. The version 2.0 code was checked into our source tree, and has been sitting there all this time. I have just uploaded it as version 2.1.