If you installed Team Explorer into Visual Studio after you applied Visual Studio 2008 Service Pack 1, you’ll need to re-apply the service pack.  If you don’t, then you’ll be running an unsupported “mixed mode” installation, meaning the core Visual Studio components will be at the SP1 servicing level and TE will be at the RTM servicing level. 

Here’s a quick way to determine if your installation is in this state:

1. Click on Help->About Microsoft Visual Studio

2. On the Help screen, click “Copy Info”

3. Paste the text into Notepad (or your favorite editor)

4. Check the version of Visual Studio:

   Microsoft Visual Studio 2008
   Version 9.0.30729.1 SP  <—indicates you have SP1 installed on Visual Studio
   Microsoft .NET Framework
   Version 3.5 SP1

5. Now check the version of Team Explorer.  If you see this, then you' have SP1 installed on Team Explorer:

   Microsoft Visual Studio 2008 Team Explorer
   Version 9.0.30729.1

However, if you see this, then you need to re-apply Service Pack 1 to bring Team Explorer up to the right servicing level:

   Microsoft Visual Studio 2008 Team Explorer
   Version 9.0.21022.8

You can download the service pack installer here.