Yes, Exchange 2007 SP1 is out. No, it has not been cleared with HMC 4.0 yet. At this point you should not install SP1. We are working on getting this tested and should have an update soon. Until then please be patient!

I am pleased to announce that the HMC Product team has finished a full regression test on HMC 4.0 with Exchange Server 2007 Service Pack 1, and not found any problems. It is therefore safe for customers running or deploying HMC 4.0 to install SP1. In fact it is recommended that HMC 4.0  customers upgrade to SP1 as soon as possible. As always they should first test carefully in their own test environment.

 

An HMC whitepaper will be made available for download from the HMC website in the coming weeks. The whitepaper describes the benefits to hosters and their customers available in SP1, and also gives you important information about the installation, including required and recommended hotfixes.

 

The whitepaper does not repeat all of the SP1 information published by Exchange. Make sure you read the release notes! There is also a wealth of explanatory information on SP1 available on TechNet.

 

Note that the Product Team's testing was not done on the original build of HMC 4.0, but on a system which had also had the important HMC rollup fixes installed. Prior to installing SP1 you should be running these fixes:

  • The "HMC Exchange Rollup" (942100)
  • The "HMC SharePoint Rollup" (943837)

See my previous post for more info on the fixes.

 

IMPORTANT NOTE: - All future HMC4.* features and hotfixes will be built assuming SP1 is installed. An early hotfix which will be available under KB 944021 takes advantage of an Exchange fix included in SP1. The hotfix greatly improves provisioning performance in environments with many MAPI-enabled organizations.