You may have heard about the recent Silverlight 1.1 alpha refresh to the original Silverlight alpha released at Mix'07. The Alpha Refresh does break the mix'07 Visual Studio templates, so you need to get an updated tools stack in order to fix the problem.

For your Visual Studio Silverlight projects to work, you need to upgrade both (1) the Silverlight runtime and (2) the Visual Studio Silverlight debug pack.  It's easy to forget #2.   (See "why is there a separate 'debug pack' for Silverlight")

I'm definitely not a expert at getting setups right. FWIW, Here are the steps I took to get things working again:

  1. Exit Visual Studio
  2. Reboot your computer (for safe measure)
  3. Upgrade the Runtime from: download URL here
  4. Uninstall the existing "Microsoft Silverlight Tools Alpha for Visual Studio 2008 Beta 2" (ie, the "Debug pack")
  5. Uninstall Orcas Beta 1
  6. Uninstall "Microsoft Visual Studio Web Authoring Component" if installed.  (The Orcas Beta 1 uninstaller is pretty good about chaining the uninstalls from many of the components, but I had to manually uninstall this one).
  7. Install Visual Studio Orcas Beta 2. (The download is huge, I used a DVD).
  8. For the extra paranoid (like me), sanity check that this install works and that you can create new projects and debug them.
  9. Reinstall the new debug pack from here (Note the July 27th publish date on the download page's "Quick Details").
  10. For the extra paranoid (like me), sanity check that you can create a new silverlight project and verify you can debug it.

 

I'm usually a magnet for setup/uninstall problems. Things went pretty smooth for me with just a hiccup around step #6.  Check out the Silverlight forums if you run into problems.