In our businesses we are seeing very seldom that there is no workflow necessary. Buying new goods means; Order, Invoice, Delivery, Pay… With SharePoint 2013 you have the choice with the good old way of SharePoint 2010 Workflows or try the new SharePoint 2013 Workflow “Engine”.

For SharePoint 2013 Workflow you might need an additional Server in a similar way if you want to use OWAS; Office Web Application Server.

Today 27/May/2013 I fixed my configuration issue and would like to share that experience.

On the WFM box:

I saw that I need Workflow Manager 1.0 and there is also the first CU available; ok, install it. Another part for that game has been automatically installed, Service Bus 1.0. Configured it on the WFM and SharePoint (only workflow manager client 1.0 needed) box. Started with SPD2013 and created a new Workflow, publishing not possible…. Errors…

Take: http://bing.com
Enter (saw it in ULS log): Current Service Bus version 2012-03 does not match the version 2012-08 specified in the upgrade policy file
Found:
Description of the Cumulative Update for Workflow Manager 1.0
http://support.microsoft.com/kb/2799754

Issue #2 told me that I should do and I did:
Uninstall CU1 for Workflow Manager 1.0
Reboot
Install CU1 for Service Bus 1.0 http://support.microsoft.com/kb/2799752 
Reboot
Install CU1 for Workflow Manager 1.0 again http://support.microsoft.com/kb/2799754
Reboot

Additionally I found that when installing CU1 for Workflow Manager that the Workflow Manager Client 1.0 also gets updated. Therefore I also took the CU1 bits for Workflow Manager 1.0 and voila on my SharePoint 2013 box the Workflow Manager Client 1.0 got updated to CU1. Rebooted all my updated SharePoint Server 2013 as well; just in case…

Learn more about the “New SharePoint 2013 Workflow Engine” http://technet.microsoft.com/en-us/sharepoint/jj556245.aspx