Earlier this week I was re-writing Scott Guthrie’s ToDo List Atlas demo to work with the release version of MS AJAX and hit an ugly snag.

When using a master page (and ONLY when using a master page, the use of some AJAX controls produced the relatively useless [unknown element] error.

I searched and searched (I even tried Goggle) and found similar issues with Beta and RC versions of MS AJAX but I was using the latest bits and the solutions for the old versions were to use the ATLAS prefix. (A kludge.)

After doing my research I phoned ScottGu (Father of ASP.NET who hired me). It was about 10:00PM EST and Scott is commonly in the office in the evening.

Scott wasn’t in the office, but he “knows everything” so even though I didn’t ;leave a message he phoned me back about 15 minutes later.

I described my problem and, of course he had the answer off the top of his head.

1.) This is only an issue when you have been using an older CTP or Beta version of MS ATLAS and then updated to release bits.

2.) It happens because the schema that intellesence is cached on a per user basis so un-installers can’t really figure out what to un-install in this case because cache locations are not determined by the installer.

3.) HALF of the fix includes installing Service Pack 1 for Visual Studio 2005 / Visual Express

4.) The other half is to explicitly flush the Intellesence cache like this….

- With Windows XP you do this by deleting all files in this directory: c:\Document and Settings\[YourUserName]\Application Data\Microsoft\VisualStudio\8.0\ReflectedSchemas

- With Windows Vista you do this by deleting all files in this directory: c:\Users\[YourUserName]\AppData\Roaming\Microsoft\VisualStudio\8.0\ReflectedSchemas

5.) Restart Visual Studio

Scott’s blog post here has the details.

http://weblogs.asp.net/scottgu/archive/2006/12/15/asp-net-ajax-1-0-release-candidate-now-available.aspx