If you plan to run Vista SP1 or Windows 2008 within Virtual PC or Virtual Server then you should install the new updated versions (released yesterday):

 

Virtual Server 2005 R2 SP1 with 948515:

Virtual Server 2005 R2 Service Pack 1 does not support Windows Server 2008, Windows Vista Service Pack 1, or Windows XP Service Pack 3

Required update available from here. Ensure you follow the instructions in the KB article. 

Virtual PC 2007 SP1:

Service Pack 1 available from here.

Service Pack 1 release notes available from here. 

[[Thanks to Niklas Engfelt]]