Support is only provided for platforms that have been tested successfully with the product. This testing will exclude operating systems that are in development/beta as there is no guarantee the results will be valid on the released version. 

In the case of Biztalk Server 2009, the server operating systems tested were:

  • Windows Server 2008 "R1"
  • Windows 2003 Server "R1" (service packs 1 & 2)
  • Windows 2003 Server R2

The System Requirements guide lists the supported platforms in detail.

Currently there are only plans to support Windows Server 2008 R2 in post-2009 versions of BizTalk Server.

This doesn't necessarily mean that Windows Server 2008 R2 will never be supported with BizTalk Server 2009 or that they won't work together. I can only advise to watch out for future support announcements.

[[Edited November 26th, 2009]]

Announced at PDC 2009, Biztalk 2009 R2 will additionally support:

  •  Windows Server 2008 R2

 

[[Edited January 18th, 2010]] 

Also bear in mind that the version of Visual Studio that you plan to use:

  • BizTalk 2009 "R1" support Visual Studion 2008
  • BizTalk 2009 R2 only supports Visual Studio 2010