Jerry Orman

Adventures in SharePoint
Posts
  • Jerry Orman

    Loading C++ Assemblies in ASP.Net

    • 11 Comments
    When you reference a Native C++ assembly from ASP.Net you may run into the following error: System.IO.FileNotFoundException: The specified module could not be found. (Exception from HRESULT: 0x8007007E) [FileNotFoundException: The specified module...
  • Jerry Orman

    Overview of My SharePoint Sites and how the data is populated

    • 11 Comments
    SharePoint gives you the ability to get a list of sites that your login account is explicitly a member of. This grouping of links is built on the server-side by the Profile Synchronization timer job that runs for each Web Application. The data is stored...
  • Jerry Orman

    SharePoint My Site link stops redirecting users to their Personal Site

    • 11 Comments
    Hopefully this can save someone some time. The symptoms are: Clicking the My Site link in a SharePoint site results in an IIS 404 File Not Found error page being returned. However, you are able to browse directly to the users My Site by browsing...
  • Jerry Orman

    System.InvalidOperationException: Mutex could not be created.

    • 11 Comments
    We've seen a few of these issues come through lately andwanted to get something posted so people can find it. If you created a custom account to run the process that ASP.NET is running in, you may encounter the following exception: System...
  • Jerry Orman

    Copying Lists with PowerShell in SharePoint 2010

    • 5 Comments
    While working through an upgrade issue, we had a need to move about 14 Discussion Boards to a subweb.  We initially went the old school route of saving the lists as a template, including the content, then creating lists using the templates. ...
  • Jerry Orman

    Debug javascript generated by webresource.axd

    • 4 Comments
    Ran across this the other day and thought someone else may find it useful. Javascript for the ASP.Net 2.0 controls is typically generated by a request to webresource.axd. For example when you add a menu control, you see the following in the page: <script...
  • Jerry Orman

    Missing Links or Access Denied in Central Admin – SharePoint 2010

    • 15 Comments
    Started running across this scenario lately, and wanted to post something up as it will make you second guess your SharePoint configuration [and sanity].  I have SharePoint 2010 hosted on my Windows 7 laptop.  In my Favorites Bar in IE, I created...
  • Jerry Orman

    SharePoint 2010 Desktop Wallpaper

    • 4 Comments
    Created this wallpaper out of the SharePoint 2010 logo . It's a PNG file that is 1920 x 1280 in resolution. Click on the link or image below to get the actual file.
  • Jerry Orman

    Nonsecure items message using Menu control over SSL

    • 7 Comments
    If you're using the new menu control that ships with ASP.NET 2.0 and SSL Termination/Acceleration, you will run into this issue. The behavior the end users will see is a warning in the browser stating something similar to: This page contains both secure...
  • Jerry Orman

    ASP.NET tab forces restart of W3SVC

    • 5 Comments
    If you change the version on the ASP.NET tab that comes with the 2.0 Framework, the entire W3SVC process restarts. If you make this type of change during a maintenance window, the impact may not be too bad, but if you have multiple application pools in...
  • Jerry Orman

    Vista + IIS 7 + Local IIS web site = error?

    • 8 Comments
    Finally got around to getting a clean install of Vista Beta 2 on my laptop and of course the first thing I install is Visual Studio 2005 and IIS 7 to see how the Local IIS option is going to play with the newly revamped IIS. Well, if you choose the default...
  • Jerry Orman

    Unable to edit documents in SharePoint 2007/2010

    • 2 Comments
    This was a pretty interesting issue as it caused some unique symptoms, as well as closing up an issue I blogged previously with regards to Self-Service Site Creation Announcements . The symptom we have was that users could upload documents to document...
  • Jerry Orman

    Deploying SharePoint 2010 Solution with PowerShell

    • 2 Comments
    Put together a small script that to help automate deployment of a solution.  The script handles the following: Install and Deploy a farm level solution Activate a web application scoped feature Activate a site collection scoped feature The tricky...
  • Jerry Orman

    Hyper-V Manager

    • 6 Comments
    Wrote this tool when I was setting up my laptop to run Hyper-V . I didn't want to have to open the Hyper-V manager and have a window running all the time, and was planning on using Remote Desktop Client to connect to the VM's so I could map drives and...
  • Jerry Orman

    Starting UserProfile service with PowerShell

    • 1 Comments
    Ran into something interesting while trying to script out a farm install. I was trying to generate generic functions to create service applications and start the associated services, and kept hitting issues starting the User Profile Sync service. The...
  • Jerry Orman

    Custom Search Web Parts in 2010

    • 1 Comments
    The SharePoint 2010 out-of-the box People Search Core Results web part in SharePoint 2010 has the ability to sort search results by name.  The option actually sorts FirstName, then LastName…likely because the XSLT displays the names as FirstName...
  • Jerry Orman

    Session loss after migrating to ASP.NET 2.0

    • 1 Comments
    The HttpOnly attribute has been added to the Session cookie generated by ASP.NET 2.0. This value is hardcoded and cannot be changed via a setting in the application. While this is documented as a breaking change in the breaking changes document (linked...
  • Jerry Orman

    Add-PSSnapIn Microsoft.SharePoint.PowerShell Failing after SharePoint Install

    • 2 Comments
    I have some PowerShell scripts that run PreRequisiteInstaller.exe, Setup.exe, and then configure a farm based on an XML configuration file.  I noticed that if Setup.exe did not prompt for a reboot, that my script would fail with the following error...
  • Jerry Orman

    Updating a SharePoint 2007 WSP in Visual Studio 2010

    • 0 Comments
    For this scenario, we have a WSP file that was packaged a few years ago and deployed to a production SharePoint 2007 environment. After the original WSP deployment, changes and additional files were pushed out directly to the file system. This brings...
  • Jerry Orman

    Mystery of the SharePoint "White Screens"

    • 4 Comments
    Randomly users start receiving "white screen" responses when browsing a SharePoint site. They essentially browse a URL and the response completes (IE shows Done in the status bar), but the response is an empty HTML page. We found that this would only...
  • Jerry Orman

    Referencing .js files for the AJAX Control Toolkit

    • 1 Comments
    I was recently working with someone that was leveraging the AJAX Extension and the Control Toolkit and they were running into an issue where a customer's environment was causing issues making requests to ScriptResource.axd. Since they couldn't change...
  • Jerry Orman

    People Picker, why don’t you trust me?

    • 4 Comments
    Working with an environment where the QA and development machines are in a Test domain, while the production farm and all the primary users are in another domain.  There is a one way domain level trust where the test domain trusts the production...
  • Jerry Orman

    What in the User Profile Service Application is going on here?

    • 7 Comments
    While working with PowerShell to build out Service Applications, I managed to get my test farm into a state where I no longer had a User Profile Service Application, but the user profile timer jobs were still around.  Trying to create a new User...
  • Jerry Orman

    Users seeing other users data in ASP.NET

    • 3 Comments
    One of the more difficult issues to troubleshoot deal with 2 users seeing each others data when they shouldn't be able to. ex. User1 sees User2's data. Most of the time while troubleshooting, you find that the problem reproduces if two people submit the...
  • Jerry Orman

    Title Bar Properties Link Does Not Work on Dynamically Created Pages

    • 1 Comments
    Ran into a problem recently while helping out on a project where web part pages were being dynamically created from a feature receiver.  Once the pages were created, everything works, except for the Title Bar Properties icon in the ribbon. When you...
Page 1 of 3 (66 items) 123