I came across this problem.  The key to this was that the documents opened fine when clicking on them, so I knew the Office installation itself was fine.  Some rogue application on install or removal had apparently removed the appropriate Content Type registry key so Internet Explorer was unable to associate the XML file extension with any application.  Restoring the default OS registry entry allowed everything to start functioning again.  Warning, modify the registry at your own risk.  Microsoft cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk.

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\.xml]
"Content Type"="text/xml"

Why did this rogue deletion of this registry key affect IE but not the InfoPath application itself?

Since all the registry entries for the application were correct the associations in the registry for opening the file are in place.  The issue is that with the 'Content Type' entry missing, Internet Explorer (more precisely Urlmon used by IE) is unable to determine what to do with this particular Content Type (XML). When this key is correct, this MIME type is found in the MIME Database registry location and the appropriate application can be invoked.

Since Office is installed the file will be passed to MSOXMLED.EXE which will determine the correct application to invoke by looking inside the XML for the appropriate entry indicating what application that particular XML is associated with.  For example: <?mso-application progid="Word.Document"?> indicates that this is a Word Document.

Let me know if this blog helped you by dropping me a note!