Well, this didn't happen when I first installed the Express Editions (Web Developer Express and SQL Server Express), but when building my demo image for the Express products using the bits downloaded from MSDN Subscriber Downloads, I ran into the same Framework versioning issue that I had when installing SQL Server 2005 Beta 2 and Visual Studio 2005 Beta 1. (See previous post for details!). 

One big snag: the download for SQL Server Express doesn't have the framework with it!  A quick fix was to use the version of the framework that's on the SQL Server 2005 Beta 2 CD ... but that's not a good solution for everyone.  So, after a little looking, I found the download for the .NET Framework v 2.0 redist that should work with SQL Server Express.  You can get it from http://www.microsoft.com/downloads/details.aspx?FamilyId=B7ADC595-717C-4EF7-817B-BDEFD6947019&displaylang=en