AppHack is a terminology used in AppCompat. Basically AppCompat detects a specific application, and applies an AppHack if necessary.

One typical AppHack is to lie about the OS version number, due to applications use the wrong logic to check the minimum OS requirement.

I only have Whidbey Beta 1 in my home machine. I need it to write samples for my blog. I don't need .Net 1.1 to run .Net 1.1 applications, because if mscoree.dll can't find .Net 1.1 on my machine, it will automatically use Whidbey. (So which CLR will my app use? )

Well, only if I can install the application.

RssBandit is a popular RSS reader written by Dare Obasanjo & Co. And that is what I am using for reading blogs.

Dare is nice enough to provide a MSI package for RssBandit.

The problem is, the RssBandit MSI package checks for .Net 1.1, and refuses to install when it does not find .Net 1.1, even though I have Whidbey beta 1 installed and RssBandit should run happily under Whidbey Beta 1.

Do we need a version AppHack for RssBandit?