On Win2008 server setup of Exchange07 SP1 you may still have the error above if you have IPV6 installed and is not your current problem.

The most likely cause of these errors are

You may not have met the prerequisites

The exchange team Blog site has made a group of XML files available which help to install all the Exchg07 with 2008 issues. These Files are available here and are used with ServerManagerCmd 

a good blog article here will walk you through the setup

Microsoft's Official link to install the prerequisites is

Remember you will need to extend Active Directory on your domain controllers using setup.com before you install Exchange too. To do this do the following

Once complete it should work BUT - did you have previous failed installs? if you did expect 

 "The Exchange server is in an inconsistent state. Only server recovery mode is available."

 to fix this follow this article and its suggested fix - do this on the domain controller

MS Fix -> http://technet.microsoft.com/en-us/library/cc411332(EXCHG.80).aspx

And forum Fix - basically the same..

http://forums.microsoft.com/TechNet/ShowPost.aspx?PostID=1186078&SiteID=17

"This problem seems to relate back to the AD.  If you have installed Exchange 2k7 previous then the AD contains information about the Exchange server that must be removed.  I deleted the 2 MS Exchange containers in the AD Users and Settings.

Then found a folder ExchangeSetupLogs and a file in there should be Exchange Setup.log.  Opening this file you should see line like

Exchange Configuration Container for the Organization is....
Exchange Organization Container for the Organization is.....

This means it found it's self in the AD.  I then went to the Domain Controller and ran ADSIEDIT.MSC. 

Under Configuration --> CN=Configuration -->CN=Services 

You should see CN=Microsoft Exchange.  All I did was remove this entire entry and everything underneath it.  The install works fine now."