We have a content Farm and Enterprise Services (ESS) Farm (where UPA is hosted), content Farm consumes UPA from ESS farm (all SharePoint 2010 obviously)

Whenever we try to load a Edit Profile Page it gives an error:

 

Error:

“The server method ‘ValidateTerms’ failed”
“The server method “GetMatches” failed

This error seems to be like coming from Javascript (out of the box) and when I tried to trace it with Fiddler I see Following requests which go as 404 but when you take a look at the Inspector section of the Fidller I could see the data was making it thru but was not showing up on the Page:-

#

Result

Protocol

Host

URL

Body

Caching

Content-Type

Process

Comments

Custom

133

404

HTTP

mysite-pstg.abcd.com

/_vti_bin/TaxonomyInternalService.json/ValidateTerms

0

iexplore:1308

134

404

HTTP

mysite-pstg.abcd.com

/_vti_bin/TaxonomyInternalService.json/ValidateTerms

0

iexplore:1308

135

404

HTTP

mysite-pstg.abcd.com

/_vti_bin/TaxonomyInternalService.json/ValidateTerms

0

iexplore:1308

 Solution:

To keep everyone updated the issue was resolved, the JSON handler entry in the web.config (of our Mysite web-app as we were accessing EditProfile page from mysite) was missing and hence the errors.

After adding that entry everything started showing up.

 <add name="JSONHandlerFactory" path="*.json" verb="*" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" resourceType="Unspecified" preCondition="integratedMode" />