A QFE for Visual Studio 2010 testing tools, which fixes some important issues faced by customers, is now available.The full list of issues fixed by this QFE can be found here and you can download this patch here. Note that Service Pack 1 (Visual Studio 2010 SP1 or Team Foundation Server 2010 SP1) is a pre-requisite for installing this patch.

 

Here is a summary of the list of issues fixed by the QFE, to help you decide whether you should apply the QFE:

Issue 1: When you run tests on the test agent that is installed on a computer that has Visual Studio 2010 SP1 installed, the tests may not run, and the following error message is logged:

"Attempted to access an unloaded AppDomain. (Exception from HRESULT: 0x80131014)"

 

Issue 2: When you run a playback of a Coded UI Test on certain Windows Presentation Foundation (WPF) controls, a Microsoft.VisualStudio.TestTools.UITest.Extension.UITestControlNotFoundException exception occurs, and then you receive the following error message:

"Search may have failed at '<name>' <control type> as it may have virtualized children. If the control being searched is descendant of '<name>' <control type> then including it as the parent container may solve the problem."

 

Issue 3: When you try to create a work item from the Test Results pane in Visual Studio 2010 after you connect to a Team Foundation Server (TFS) server, a System.OutOfMemory exception occurs, and the creation operation fails. This issue usually occurs if the TFS server has many builds.

 

Issue 4: When some tests run in a build operation, some builds that are queued in a TFS server stop responding. Additionally, the following error message is logged in the build log:

Waiting to publish...
Publishing results of test run <build name> to http://<TFS server address>:8080/tfs/DefaultCollection...
The process cannot access the file '<directory>\data.coverage' because it is being used by another process.
Publish failed or canceled.