After cleaning my house, I needed to go through the painstaking process of getting my dev environment up and running on Vista. Here's what I got installed and the order I did it.

  • Windows Vista RC1 5728
  • Visual Studio 2005 Team System
  • Windows Mobile 5.0 PPC SDK
  • Windows Mobile 5.0 SP SDK
  • patterns & practices Mobile Client Software Factory

 

Here's the order:

  1. Install Vista RC1 5600 via Remote Installation Service. Found out it was the Enterprise not Ultimate SKU.
  2. Downloaded Vista RC1 5728 from Connect (of all places! I'm a Microsoft Employee but I have to get it through the Beta Program *sulk*) and upgraded Vista RC1 5600 in place.
  3. Installed the Dogfood patch for Windows Mobile Device Center
  4. Ran Windows Update while Device is tethered to USB. (to install WMDC)
  5. Installed Visual Studio 2005 Team System
  6. Turned off User Account Control (UAC) to get the project templates to install properly. Read: Zandona's Workaround also here for more tips.
  7. Install Windows Mobile 5.0 SDK PPC
  8. Install Windows Mobile 5.0 SDK SP
  9. Install Guidance Automation Toolkit and Extensions. (Mobile Client Software Factory requires this)
  10. Install Mobile Client Software Factory (few errors appeared, CabGen and OpGen failed to install. Check Dependencies section. )
  11. Install FXCOP to get the Microsoft.Cci.dll file that MCSF requires.
    1. If you have the Microsoft.Cci.dll file only, then you should place it in ObGen\Lib and CabGen\Lib
  12. Open up ObGen.sln and CabGen.sln and Rebuild All.

 

That's it. Total time? Two days. Will not exactly 48 hours but spent half the time looking for answers to get all the parts working, esp. the MCSF dependencies. If you're not interested in the MCSF components, then you can stop at 8.