SQL Compact 3.5 SP1 is now available for CE 5.0 and CE 6.0 - the Platform Builder catalog update is part of the CE 5.0 and CE 6.0 Monthly Update July 2008.

Here's a link to the CE 6.0 July Update 2008 (includes SQL Compact 3.5 SP1)

Here's a link to the CE 5.0 July Update 2008 (includes SQL Compact 3.5 SP1)

The SQL Compact 3.5 SP1 install includes both native and managed interfaces.

- Mike