Mike Ormond's Blog

Musings on mobile development and Windows Phone 7 in particular.

My Hoster Doesn't Support ASP.NET 3.5

My Hoster Doesn't Support ASP.NET 3.5

  • Comments 7

And I'm not happy about it. ASP.NET 3.5 is offered to new customers but not existing customers. When I asked when it would be available I was told "Unfortunately we do not have an estimated time for current accounts to be able to upgrade to ASP.NET 3.5."

To me the lack of a timeframe is simply unacceptable. I'll be looking around for a more pro-active hoster when it comes time for renewal. GoDaddy.com you should be doing better than this.

Technorati Tags: ,
  • PingBack from http://msdnrss.thecoderblogs.com/2008/03/26/

  • Well done for naming and shaming!

    I hate the whole "new customers only" thing

    I use http://www.csnewmedia.co.uk/

    Only a small host but they have amazing customer service.

    Mention andy@andyparkes.co.uk if you get in touch so i can get a refferal?

    Cheers

    Andy

  • It's supposed to be an easy upgrade from 2.0 to 3.5. They don't even have to change anything on the IIS. Who knows why they are not upgrading it for existing customers...

  • You can get .net 3.5 on Godaddy IIS7 boxes, only new accounts can currently choose IIS7. Just ask for a migration to an IIS7 boxes(You may need to ask for an escalation if they say they can't do it).  Automated migration has yet to be enabled, but will in the future.  .NET 3.5 for IIS6 is coming soon.

  • Looks like .net 3.5 for IIS6 should have gone live today.  I do wish that godaddy was more transparent in this regard. He would alleviate alot of headaches.

  • Thanks for the comments and suggestions of alternatives. Sean, I've had a look again today and I still don't have 3.5 as an option in my control panel. I'll keep an eye out though in the hope it's imminent. Mike

  • Apparently I jumped the gun a bit.  3.5 is available on some servers but not all.  Full roll out should be about a week away.  You won't have to change anything if your app pool is currently set to 2.0.  It will appear as 2.0/3.5 in the control panel.  Good Luck.  I know I have been looking forward to it myself.

Page 1 of 1 (7 items)