I'd like to summarize a few known issues with VS/VWD intellisense and respective solutions or workarounds.

Symptom: No markup validation and no code intellisense. When you type invalid element or attribute, red squiggly line does not appear. No C#/VB code intellisense or when you add server control, such as asp:button, code intellisense does not pick it up. When you open document outline window (View | Other Windows | Document Outline), it stays empty no matter how long you wait.

Possible cause: some application keeps broadcasting messages to all windows breaking idle loop. Visual Studio runs several tasks at idle time. Idle time is when application message queue is empty. If messages keep coming, idle loop may never run. Idle tasks include HTML parsing, validation and document outline building. Code intellisense gets updated partially on idle, partially in a background thread. We have identified at least one application that breaks idle loop: PowerDVD Launcher. I have also seen reports that Visual Studio idle loop was not running correctly in XP on MacBook Pro under Apple Boot Camp, at least in early versions. According to this report, some video drivers may also exhibit the problem. New Microsoft Laser Mouse 6000 may be causing the problem as well.

Solution: try disabling resident applications one by one until the problem goes away. This way you can figure out which app breaks the idle loop. Try upgrading video driver. Try switching to a different mouse, preferably wired and see if the issue goes away.

 

Symptom: No intellisense for Atlas/Ajax controls. Markup inside UpdatePanel may get mangled after switch from Design view.

Cause: change of Microsoft Ajax namespace from atlas to asp. Change in ASP.NET Ajax assembly location.

Solution: See here: http://blogs.msdn.com/mikhailarkhipov/default.aspx

 

Symptom: You keep getting error "__o is not declared" in the Error list

Solution: see here: http://blogs.msdn.com/mikhailarkhipov/archive/2006/04/20/580165.aspx

 

Symptom: intellisense errors when using "</script>" string in C# or VB script block.

Solution: see here http://blogs.msdn.com/mikhailarkhipov/archive/2005/11/09/490930.aspx

 

Symptom: validation errors in ASP.NET controls in content page. Errors go away if you keep master page open.

Solution: install Service Pack 1 or keep master page open.