The WSE team has put out an update to their earlier WSE 3.0 technical preview, but before you rush out and install it be aware that the new WSE 3.0 July CTP REQUIRES the July CTP of .NET Framework 2.0 or the July CTP of Visual Studio 2005.  The July CTPs of the .NET Framework and Visual Studio are only available to MSDN subscribers.

So if you want to see the updates since the original WSE 3.0 CTP, go get it:

Web Services Enhancements (WSE) 3.0 July Community Tech Preview for Microsoft .NET

Web Services Enhancements (WSE) 3.0 July Community Tech Preview for Microsoft .NET Redistributable Runtime MSI

   -Matt