A fairly common question to support is can I use this build of SQL with my build of ILM.  Yes, FAQ may answer some of this, or System Requirements, but normally it is more specific than that, so I with my team have created this document to help out.

What version of SQL Server for the backend.

http://social.technet.microsoft.com/wiki/contents/articles/what-version-of-sql-server-to-use-on-the-backend.aspx