Now that BizTalk Adapter Pack is part of BizTalk Server 2010 installation media, there have been some confusions related to Adapter Pack upgrade. There have been some questions/comments floating that upgrading to BizTalk Server 2010 also upgrades existing Adapter Pack installation to BizTalk Adapter Pack 2010. Well, this is not correct. Even though BizTalk Adapter Pack 2010 is now shipped with BizTalk Server 2010, one would need to upgrade Adapter Pack separately. Here’s how you would go about upgrading BizTalk Adapter Pack 2010:

  1. Stop all applications that reference the adapter DLLs.
  2. Uninstall existing Adapter Pack.
  3. Uninstall existing WCF LOB Adapter SDK.
  4. Install WCF LOB Adapter SDK 2010. WCF LOB Adapter SDK can also be installed from the BizTalk Server 2010 installation media.
  5. Install BizTalk Adapter Pack 2010.