A couple of days ago I reinstalled VS 2008 RTM version and I happily tried to create a website. Unfortunately, my productivity was totally ruined ‘cause most of the toolbox items were missing. To be exact, I only had the HTML tab.

Here are the steps to get your items back. Navigate to C:\Users\<username>\AppData\Local\Microsoft\VisualStudio\9.0 (on Vista or Longhorn) or “C:\Documents and Settings\<username>\Local Settings\Application Data\Microsoft\VisualStudio\9.0” (older Windows versions) from a command prompt or in explorer (you may need to configure explorer to show hidden folders: Tools -> Folder Options -> View -> check Show hidden files and folders). Here, just delete these files:

·         toolbox.tbd

·         toolboxIndex.tbd

·         toolbox_reset.tbd

·         toolboxIndex_reset.tbd

Then restart VS 2008 and the toolbox should look normal again. Same steps apply to VS 2005 (just replace 8.0 with 9.0 in the path)

If you still have problems, try the following:

-          Check that the .NET Framework is properly installed. You could use the script at .NET Framework 3.5 Installation validation tool

-          Try restoring the IDE's default settings: from the folder where VS 2008 is installed (eg. %ProgramFiles%\Microsoft Visual Studio 9.0\Common7\IDE), run devenv.exe /ResetSettings. You can also specify a VSSettings file to restore settings from.

-          To clears all SkipLoading tags added to VSPackages, run devenv.exe /ResetSkipPkgs.

-          Launches the IDE in safe mode loading minimal windows: devenv.exe /SafeMode.

If your controls are grayed out, you might want to check your mouse. This post shows the effects of a weird interaction between some wireless mice drivers and the idle timing that ASP.NET designer relies on.