Today's presentation (number 89) to the assembled PR agencies of Microsoft nearly didn't happen. I've already presented to this group before, several months ago, and had done the standard user interface pitch and possibly even the outlook one as well (it gets hard to remember) so the purpose of this one was to get across the server end of the Office system. This is what I refer to as the capabilities overview.  I can do several hours of demos on this by now without a great deal of preparation, showing how SharePoint is the hub for the new system.

Normally though, I'm doing this presentation either in our offices in Reading or in London so I use our demo server sitting under Chris' desk over the network.  This works pretty well on the whole, except if the wireless network is ropey but usually its fine.  Today though I had to do this at Webber Shandwick's offices and so we needed to build a new server for the demo.  The trouble is when you take the sharepoint server out of the corporate network and therefore out of the domain, you also need to take with you a DC (domain controller) for the sharepoint box to authenticate users against. We have a VPC (virtual PC) which combines the two servers. 

We built this on my Dell XPS which has 2Gb of RAM just using a pared down Windows Server 2003 running in the minimum memory required and leaving about 1.7Gb of memory just for the VPC.  The disk was 100% defraged too and STILL it was dog slow.  It was taking 30 seconds to respond to a key stroke at the login.. just rubbish.  So after working on that until 11:30 last night I gave up and used a PowerPoint mock up of the demo instead.  To be honest, its a pretty good way to do the demo - it gets the point across (if you can remember the script) and is totally reliable. The other option was to RAS in to the corp net and connect back to our demo server which would be a bit slow but bearable - however Vista 5505 decided to forget how to read my security smart card.. grrrr.  Then when I get to the presentation, Vista 5505 refuses to project on the projector even after a reboot.. grrr... and then suddenly decides it will afterall.  So I think the best thing to do is install the SharePoint server locally and let it authenticate against a VPC of just the DC in about 256Mb of RAM.  I think that should work well.

I quite like the Dell XPS or the "pimptop" as it has become known in the team owing to its blue neon side lighting.  It seems to run Vista pretty well and the screen is beautiful.  It's not core duo though so is a bit dated now.  I use it a lot for one on one briefings without the projector for that reason.  Vista and Office look great on it.  My toshiba M4 Tablet seems to have a lot more problems with drivers though - the screen driver being the worst.  It's a good little (well quite big) machine generally but unless Toshiba sort out the drivers I think it will get relegated to back up machine.  We are expecting some new HP tablets soon which are Vista capable so promise to be a better experience.. can't wait.  I also have a little (it is little this time) Q1 from Samsung which is very cool - one to use with a tech audience just for sheer gadget envy it induces :-) 

It's running Windows XP sp2 with Office beta 2 and runs really nicely.  However the pointer is not like the tablet and is purely pressure sensitive rather than tracking the point as you move near the screen which is clumsy and means you end up wanting a mouse and a keyboard very quickly.  I also find I end up want a bigger screen - what we really need is all that in one package - imagine that.. especially if it would all fold up and you could carry it round together -- nah it'll never catch on..

Anyway, somedays the technology wants to have a duvet day and who can blame it, so do I somedays.  Undeterred though I find myself looking forward to build 4319 of Office just to find out what is new.. crikey I'm still a nerd at heart.. oh yeah I might be in marketing but inside the tech force is still strong :-)