Holy cow, I wrote a book!
The naming convention for HRESULT is
where the facility portion (and the underscore) is omitted
if the facility is FACILITY_NULL
Good luck finding anybody who follows this naming convention.
Okay, fine, if you look closely you might be able to find some
people who do.
Actually, I guess I was a bit too pessimistic when I said
nobody follows it.
It seems that the majority of Windows components do follow this
convention, although there are some notable exceptions.
There are also some people who decided to confuse matters further
by using the HRESULT convention for error codes
returned by GetLastError()!
I apologize for the confusion this has caused.
Pre-emptive clarifying remark:
The examples given in this article are
and are not intended to be comprehensive.