Install MOSS 2007 & WSS 3.0 on Windows Server 2008 R2 – you will need SP2 slipstream

Install MOSS 2007 & WSS 3.0 on Windows Server 2008 R2 – you will need SP2 slipstream

  • Comments 8

Windows Server 2008 R2 RC is avaliable several days ago. You may ask questions: What if I want to install WSS/MOSS on Windows Server 2008 R2? Is that supported?

The answer: WSS/MOSS RTM & SP1 is not supported on WS2008R2. But with SP2, it is supported. If you try to run the installer without SP2 slipstreamed, it would be blocked and you cannot continue. Meanwhile, if you want to use SQL Server 2008, you will also need to apply SQL Server 2008 SP1 on it after installation.

snap014

So slipstream build of WSS and MOSS SP2 is required. WSS SP2 slipstream build can be found here: x86 x64. There’s no slipstream build for MOSS so you need to create your own one. Here’s a quick guide:

Remove all stuff inside the Updates folder of your MOSS installation directory. Download both wss and moss SP2 packages, extract them in command line using /extract:drive\path option,  and then put all into the Updates folder. Delete Wsssetup.dll, this is important. Otherwise only WSS SP2 will be installed.

More details can be found on TechNet.

 

With SP2 slipstreamed, you can run the installer without any problem now. After installation, site version will be 12.0.0.6421.

snap015 

Windows Server 2008 SP2 is also supported by MOSS/WSS SP2.

Leave a Comment
  • Please add 2 and 7 and type the answer here:
  • Post
Page 1 of 1 (8 items)