25 Feet Below the Surface

Architecture, Paradigm & Solutions

Create/Debug ASP.NET Web Application using Visual Studio 2005 on IIS 7.0 (Windows Vista)

Create/Debug ASP.NET Web Application using Visual Studio 2005 on IIS 7.0 (Windows Vista)

  • Comments 3


I wanted to blog about this since Windows Vista has been released and we will probably see a lot more such issues. This was an issue that one of my colleagues (Pradeep Martin Anchan) worked on and fixed it. Pradeep is one of the few people on our team who has actually completed the IIS 7.0 training and walkthroughs and all that stuff. He was also the first one to install the Windows Vista Beta and start exploring IIS 7.0. Unlike me of course, I still need to get Vista installed but have been putting it off for one of those lazy days. So here is a brief summary of the problem and the Resolution.

PROBLEM
========
Customer had Windows Vista RTM, Visual Studio 2005 PRO, IIS 7.0 and of course .NET Framework 2.0. While trying to create a new web application he was getting the following error.

"Unable to create the Web 'http://localhost/<website>'.
The Web server does not appear to have the FrontPage server extensions installed."

CAUSE
======
The Visual Studio 2005 IDE uses the IIS metabase APIs to create and configure applications in IIS. So, we must install a metabase compatibility component for IIS 7.0.

RESOLUTION
===========

Install the metabase compatibility component for IIS. 

a. Open the Control Panel and click on Programs and Features. In the left pane, click Turn Windows features on or off.
b. Expand Internet Information Services. Expand Web Management Tools and then expand IIS 6 Management Compatibility.
c. Select the IIS Metabase and IIS 6 Configuration Compatibility check box.
d. Click OK to start the installation process.

On a Windows Vista machine we need to take care that Visual Studio 2005 is running in the context of the administrator account. Even if we loging with Admin credentials, Vista will run applications with limited privilages. Make sure that you right click Visual Studio 2005 and choose "Run as Administrator"

 

Comments
  • I wish this worked - I can't register .NET 2 with the server - it fails a puts dozens of messages in the event log. I can't get IIS 7 to even serve up a straight HTML document!

  • Hi JayPee,

    Have you checked the "Common Http Features" under IIS-->WWW Services and verified that static content is enabled?

    Also make sure that under "Application Development Features" ASP.NET is enabled.

    You will find these features listed when you go to the Control Panel-->Programs-->Turn Windows Features on or off-->Internet Information Services

    Hope that Helps!!!

  • Debugging Subtext on Windows Vista using IIS7 and Visual Studio 2005

Page 1 of 1 (3 items)