Here is the situation and i must tell you that i cracked my head for almost 4 hours on this :(

I had 1 MOSS Server (Complete install) connecting to 1 back-end SQL Server. We decided to add 1 more MOSS Server and 1 more SQL Server in the farm. Database Mirroring to be done on the 2nd SQL Server and the 2nd MOSS Server to be added as a dedicated Index Server. I repro-ed everything in the Lab.. and guess what - everything went fine.

Now its turn for the production box and Murphy's law kicked in....

First - SharePoint Configuration Wizard failed with an exception "Error during encryption or decryption. System error code 997".

After spending some 2 hours on this (big thanks to Rickey and his Blog) it got fixed. Follow these instructions if you face the same problem:

  1. Disconnect the new server from the farm
  2. On the old server run the following command to update the Farm Account
    stsadm -o updatefarmcredentials -userlogin "Domain\UserName" -password "<YourComplexPassword>"
  3. Go to the new Server and Run SharePoint Configuration Wizard to Join the server to the Current Farm
  4. It will join successfully.
  5. Before you do anything else run the following command
    stsadm -o updatefarmcredentials -userlogin "Domain\UserName" -password "<YourComplexPassword>" -local (Note: -local has been added as a new operator)

Now the real problem - I started the Windows SharePoint Services Help Search - it went fine. As soon as i tried starting Office SharePoint Server Search i received the following error: "An unhandled exception occurred in the user interface.Exception Information: Unable to connect to the remote server "

After several hours of hitting my head against the wall, this is what i figured out and it worked for me. The steps are really simple:

  1. Go to Run >> type Services.msc
  2. Found out that Office SharePoint Server Search was disabled
  3. Enable the Service with the user account under which SharePoint is supposed to Run
  4. Open up Command Prompt and browse to: C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\BIN
  5. Type the following command to start the Search Service :
    stsadm -o osearch -action start -role index

1 more thing >> In the 2nd WFE, Disable the Windows Firewall to allow incoming connection.

 

Everything worked for me and hope this blog helps somebody else too. Next week I will write about how to configure Database Mirroring for SharePoint and how to make the newly added Mirror Server to be the Principal Server (SharePoint Context)

c ya...

This posting is provided "AS IS" with no warranties, and confers no rights.