CSS SQL Server Engineers

This is the official team Web Log for Microsoft Customer Service and Support (CSS) SQL Support. Posts are provided by the CSS SQL Escalation Services

SQL Server 2008 Express, .Net Framework 2.0 SP2, and 3.5 SP1 explained...

SQL Server 2008 Express, .Net Framework 2.0 SP2, and 3.5 SP1 explained...

Rate This
  • Comments 8

Many of you may have read my post about dependencies with Visual Studio 2008 SP1 and the .Net Framework 3.5 SP1 and SQL Server 2008. I have some related information to provide to you about SQL Server 2008 Express.

If you are a user of SQL Server 2008 Express, there is some new information you should know about. I created a separate post here because the other post was getting pretty big and this information is something specific to SQL Express SKUs so didn't want it to get lost in the message.

If you try to download and install SQL Server 2008 Express (I'll call this SQL Server 2008 Express Core which means NOT SQL Server 2008 Express with Tools or NOT SQL Server 2008 Express with Advanced Services. I'll talk about these later. I'll call all of these together as a group SQL Express editions), you may receive the following dialog box error when first trying to run setup:

image

The error message is technically correct. SQL Express Core requires .Net Framework 2.0 SP2 at a minimum (SQL Server 2008 Express requires updates to 2.0 specifically in .Net Framework 2.0 SP2) but does not requires updates specifically in .Net Framework 3.5 SP1. However, the instructions will mislead you on this dialog box. You can search as hard as you want but you will not find a .Net Framework 2.0 SP2 package to install on your machine. What you need to do is install .Net Framework 3.5 SP1 which includes .Net Framework 2.0 SP2.  We actually did provide instructions for you to install these requirements on the download page for SQL Server 2008 Express at:

http://www.microsoft.com/downloads/details.aspx?FamilyID=58ce885d-508b-45c8-9fd3-118edd8e6fff&DisplayLang=en#filelist

On this page it says:

Instructions

Note: You must have administrative rights on the computer to install SQL Server 2008 Express.
We recommend that you read the Release Notes and Readme before installing SQL Server 2008 Express.

Note that neither .Net Framework 3.0 or .Net Framework 3.5 RTM includes .Net 2.0 SP2 which is why you still must install .Net 3.5 sp1 on a platform such as Windows Vista SP1.

Also on this list is the requirement to install Windows Installer 4.5. Be sure you have completed both of these steps first before installing SQL Express (any edition).

Since SQL Server Management Studio ships with SQL Server Express 2008 with
Tools
and SQL Server 2008 Express with Advanced Services, the requirement is you must have the complete .Net Framework 3.5 SP1. So for these editions, you may get a dialog box error like this:

image

For all Express editions, if you don't have Windows Installer 4.5 installed, you will see a dialog box like this:

image

So you must install Windows Installer 4.5 RTM before proceeding. A comment here about this requirement. The specific minimum version we are checking for is Windows Installer 4.5.6001.22159. You can see the version on your computer by checking the Product Version of msiexec.exe.

If you don't have it already installed, you will need to install Windows PowerShell 1.0 only if you are installing SQL Server Express 2008 with Tools or SQL Server 2008 Express with Advanced Services. If you don't do this, you will get into several screens of the install and setup will fail with the following rule:

image

The good news is that you can go ahead and install PowerShell while on this screen and re-run the rule check to proceed with setup.

A few other comments about this issue and SQL Server 2008 Express packages in general:

1) We don't automatically install .Net 3.5 SP1 and Windows Installer 4.5 (as we do with other editions of SQL Server 2008) because we are trying to keep the size of our install packages for Express as small as possible.

2) For SQL Server 2008 Express Core, you have a choice of 3 packages:

SQLEXPR32_x86_ENU.exe - This contains 32bit binaries only. If you are only installing on a 32bit operating system, use this package.

SQLEXPR_x86_ENU.exe - This contains the same binaries as the 32bit only package plus some x64 binaries so that you can install SQL Express in a WoW environment. Use this package if you want to install SQL Server 2008 Express 32bit on a 64bit operating system.

SQLEXPR_x64_ENU.exe - x64 package for native x64 SQL Server Express on a 64bit operating system.

3) When you install SQL Server 2008 Express with Tools you may be confused when you see some of the setup screens say "Express with Advanced Services" like this following feature screen selection (you may also see this on the Product Key screen):

clip_image002

This screen actually came from the SQL Server 2008 Express with Tools package I installed on my machine. In this case the reason I know I don't have the SQL Server 2008 Express with Advanced Services package is because I don't get to pick Full-Text Search or Reporting Services as features. These two features are ones that are in the actual Advanced Services package but not available in Express with Tools package.

Please read these other excellent blog posts to learn more about SQL Server 2008 Express:

http://blogs.msdn.com/sqlexpress/archive/2008/08/07/what-s-up-with-sql-server-2008-express-editions.aspx

http://blogs.msdn.com/sqlexpress/archive/2008/08/11/sql-server-2008-express-is-now-live.aspx

http://blogs.msdn.com/sqlexpress/archive/2008/08/22/the-sql-express-2008-family-is-getting-bigger.aspx

http://blogs.msdn.com/sqlexpress/archive/2008/08/24/faq-switching-between-sql-server-2008-edtions.aspx

 

Bob Ward
Microsoft

logo-header-sql08-dg

Leave a Comment
  • Please add 7 and 6 and type the answer here:
  • Post
  • PingBack from http://hubsfunnywallpaper.cn/?p=2833

  • GREAT post, Bob!  What would we do without you?

  • There is a new posting in the PSS SQL Server blog that gives even more detail about installing the SQL

  • I installed VS2008 SP1 then SQL Server 2008 Express with Advanced Services. Later, I found in my VS2008 Setup & Deployment project that the available pre-requisites for selection is only SQL Server 2005 Express SP2. May I know where to download an official package from Microsoft to enable SQL Server 2008 Express in the list?

  • There is a wonderful post over the SQL PSS blog about installing SQL Server Express and the various errors

  • My XP SP3 x86 has the following .net framework installed, I could install SQL 2008 Express SP2 without installing .net 3.5. My question is what's the minimum requirement of .net framework, for installing SQL 2008 Express SP2.

    2.0.50727.3615

    3.0.4506.3636

  • 2 Gb of operative memory and all kernels of the processor (or at least 2-4, since it already the standard for desktop computers) apply to corporation Microsoft on decrease in restrictions in Express release on use at least. It is necessary for small server appendices on which the given edition is focused. Also I ask to reconsider the user interface of the dispatcher of reports since it morally obsolete and needs processing as MS it does with W7 and W8.

  • had problem with netframework updates my self on futher inspection of the up dates the kbs on them where zero to zero kbs did not install updates as possible virus infection also check valid date of entry

Page 1 of 1 (8 items)