CSS SQL Server Engineers

This is the official team Web Log for Microsoft Customer Service and Support (CSS) SQL Support. Posts are provided by the CSS SQL Escalation Services

JDBC 1.x: “She sure was a good ship”…

JDBC 1.x: “She sure was a good ship”…

  • Comments 2

OK, OK – the title is a complete rip-off of Bob Ward’s post about SQL Server 7.0, but the sentiment is the same.  On June 25th, support for the the Microsoft JDBC driver versions 1.0, 1.1, and 1.2 will end.  Much like SQL Server 7.0, the v1.x versions of the driver were a major milestone for Microsoft’s support of JDBC.

The driver we supported prior to v1.0 was the SQL Server 2000 JDBC driver.  You may or may not know, but this driver was really a DataDirect driver that we licensed for redistribution.  We were responsible for supporting problems with it, but ultimately, we had to engage DataDirect if there was a bug or we needed code review.  As you can imagine, while DataDirect was very responsive and we had a great working relationship, it wasn’t necessarily the best long-term solution for our customers since we ultimately had to rely on a third-party for the deep code work.

Therefore, we decided to release a version of the driver that we owned entirely and could completely support on our own.  While that meant we had to develop a lot more expertise with Java and JDBC, we felt it was the right decision for our customers.  This became the SQL Server 2005 JDBC v1.0 driver and was our first real foray into JDBC.  We later released v1.1, but the next real big jump was v1.2 where we completely rewrote a huge portion of the data flow between the driver and the server (I’ll bet David Olix still has nightmares about it!).  v1.2 was also the first version where we were officially certified for use with a version of WebSphere.  This relationship has continued, but I remember the long arduous process to get that first certification completed.

So, in summary, while the v1.x drivers were great for their time, their time has passed and if you haven’t already done so, you need to look at upgrading to at least v2.0 (personally, I would recommend you go to v3.0 to give your application the longest possible supported lifetime) so that you stay in a supported configuration.

Leave a Comment
  • Please add 8 and 6 and type the answer here:
  • Post
  • Hello, what about v4.0? I know, not yet released but is it superior than v3.0 or contains breaking changes?

  • Hypothesis,

    We always strive for the next release of our products to be better than the previous release.  Based on what I know about v4.0, I would expect more of the same.  I am not aware of any breaking changes coming in v4.0, but that doesn't mean there won't be any.

    Evan

Page 1 of 1 (2 items)