CSS SQL Server Engineers

This is the official team Web Log for Microsoft Customer Service and Support (CSS) SQL Support. Posts are provided by the CSS SQL Escalation Services

Analysis Services - Errors when trying to add a User as a Server Admin

Analysis Services - Errors when trying to add a User as a Server Admin

  • Comments 2

When trying to add a user as a Server Admin to Analysis Services, you may encounter one of the following errors:

The following system error occurred:  The trust relationship between the primary domain and the trusted domain failed.
(Microsoft.AnalysisServices)

Or

The following system error occurred:  No mapping between account names and security IDs was done.
(Microsoft.AnalysisServices)

When you see this, you want to look for an entry in the Admin list that looks like a SID (Security Identifier) instead of the actual account name.  For example:

image

This emails that the account that was listed as a Server Admin was probably deleted, or if you were in a Trusted Domain scenario, the Trust may have been broken preventing the ability to resolve the SID to the account name.

If you see this, and then add a new user, when you hit on the OK button on the bottom, you will see one of the two errors above.  The first error could come up if you are in that Trust Domain Scenario and the user was from a different domain.  The second error may come up if it was just a user in the same Domain as the SSAS Service.

To get around this issue, remove the SID account and then you should be able to add the new Admin account normally.

 

Adam W. Saxton | Microsoft Escalation Services
http://twitter.com/awsaxton

Leave a Comment
  • Please add 6 and 2 and type the answer here:
  • Post
  • It works. Really Helpful I tried many ways. Thanks Adam.

  • Thanks for this, this worked for us. We had a situation in which our only SSAS admin was an SID number and it wasn't letting us add any other accounts. But, with the same login that wasn't able to add accounts I was able to remove the SID user and then was seemingly granted permission by SSAS add another. After that everything was good.

Page 1 of 1 (2 items)