Everett SP1 Tech Preview and VSA / VSTO

Everett SP1 Tech Preview and VSA / VSTO

  • Comments 3

Updated information about VSTO below

As you may know, the .NET Framework 1.1 ("Everett") Service Pack 1 Tech Preview is available for download. You should try to install this on your non-production machines and test to make sure your existing applications continue to run. Please report any problems you find to the .NET Framework Tech Preview newsgroups.

Just a quick word of warning though:

I wasted about 5 hours the other night tracking down a "bug" in a brain-dead simple VSA host app I had built. Turns out that whilst the JScript engine works flawlessly (of course :-) ), the VB VSA engine doesn't work in the Tech Preview. Basically any attempt to call IVsaEngine.Run will result in a "The parameter is incorrect" error due to a communication problem between the native and managed code portions. It will apparently be fixed for RTM.

Update Monday 19th July:

It turns out that VSTO 2003 is also affected by this same problem, but in a different way. VSTO customisations will run OK with the Tech Preview, but they may not get unloaded when you close the associated Word or Excel document. This means that if you hook application-level events, or you run code off a timer, or perform some other actions that can get triggered by things outside the scope of the document, your code may continue to run and receive these notifications even when the original file is closed. Closing down the host application will of course unload the code correctly.

This message brought to you by the number '4' and the letters 'F' and 'S.' You figure it out ;-)

  • I am having the same exact problem with the VSA engine saying that "the parameter is incorrect". I am using the XP SP2 release candidate on a tablet pc. Is there a way to circumvent this problem by unistalling .net framework 1.1 SP1 and reinstalling a version of the framework without this problem? I guess what I'm asking is what assurance is there that MS is going to fix this problem by RTM or should I be looking for alternate solutions. Thanks for your insight, Jason
  • Hey Jason,

    Obviously things are always subject to change, but I am told that the VSA bug will not be present in the RTM version of Everett SP1 (and XP SP 2).

    I don't know if you can uninstall SP1 if it was part of the XP SP 2 install... sorry.

Page 1 of 1 (2 items)