Many of you have downloaded the Visual Studio 2005 release candidate that was made available last month.  It is exciting to see an almost final version of the product.  However, it is important to keep in mind that most of the developer focused beta software Microsoft has released (ex. WinFX) requires Beta 2.  Also, Beta 2 has a go-live license, while the release candidate does not.  Since you can't run both versions at the same time, you may actually end up with two real/virtual machines.  At any rate, when working with Visual Studio 2005 versions, there are a couple of things to keep in mind.

MATCHING VERSIONS OF SQL SERVER 2005

If you are going to install SQL Server 2005 on the same machine as Visual Studio 2005, is important to match the correct SQL Server CTP with the correct version of Visual Studio, since SQL Server 2005 also requires the 2.0 .Net Framework.  For Visual Studio 2005 beta 2, you can use either the April or June CTP of SQL Server 2005.  The June CTP is the recommended version.  For the release candidate of Visual Studio 2005, you need to use the September CTP of SQL Server 2005.

VERSIONS OF .NET FRAMEWORK 2.0 BETA 2

Even though the developer focused beta products all use beta 2 of the 2.0 .Net Framework, it turns out that they use slightly different versions.  All of the beta 2 versions are 50215.x.  The later the .x, the greater the version of beta 2.  I believe the original beta 2 was .44 and the beta 2 released at PDC was .322.  The key is that all of these versions are backwards compatible, so software which worked with .44 will also work with .322.  The trick is that when you install software which requires the beta 2 framework, if a version is already installed, it will not be upgraded, even if a newer beta 2 is required.  This is why some ReadMe files encourage you to install the product which contains the latest beta 2 framework before you install products which use older versions.  For example, the SQL Server 2005 June CTP ReadMe says to install it before you install Visual Studio 2005 Beta 2.

If you already have installed a bunch of products which use the beta 2 framework, all is not lost.  You don't need to uninstall everything and reinstall in the correct order.  You can simply uninstall just the beta 2 .Net Framework 2.0, and then install the newer product and beta 2 framework.  After the install, the existing products will still work fine with the newer version. 

IMPORTANT:  Some of the products which use the beta 2 framework won't uninstall if the framework isn't present, so don't uninstall it unless you are certain you have a version to re-install.

-David